summaryrefslogtreecommitdiff
path: root/dev-ruby/nanotest
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/nanotest
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/nanotest')
-rw-r--r--dev-ruby/nanotest/Manifest3
-rw-r--r--dev-ruby/nanotest/metadata.xml11
-rw-r--r--dev-ruby/nanotest/nanotest-0.9.4.1.ebuild22
3 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/nanotest/Manifest b/dev-ruby/nanotest/Manifest
new file mode 100644
index 000000000000..726f299ba46b
--- /dev/null
+++ b/dev-ruby/nanotest/Manifest
@@ -0,0 +1,3 @@
+DIST nanotest-0.9.4.1.gem 7680 BLAKE2B d6353949241c85df6286728938c017881763c332fe7deebfe641cf2ca85e65d9934ea4567494afd775d54171e5ebc86558ff1c376d6519fb9ff0f6d5addc1bfa SHA512 0ef48c747130fadb5f11818e131780b05032d57102a142293e29f135f75c1dd57c75005479880974342c257c645b3d2a4489432049683e3421743fa3e252cc09
+EBUILD nanotest-0.9.4.1.ebuild 501 BLAKE2B 9253b643f5e7885713c4fc82c279d11a550db81c8eef69cbc5de4a25bd49432b780d54974a5ccc95c1197d7965392b2160373cb945f7855ae90c3eb6d1898c55 SHA512 6905b02d9c378780c4c6765b1ec0eea0b38b49915a52d2b95e148c0ed939f07ba7a1d9fb9c9e5293c873512474228aa475a1dec94404a133437f42549d8a55e3
+MISC metadata.xml 341 BLAKE2B e0a1896a9c6b6c9e1dbe1824237ab79ff59ef337a6c38ea9a37d3244fa69dd58a6b32456eded92cc73ab769b15402c6cc3fc557db5133ee44cf5b9bb666d882e SHA512 9211350efb92ba99f2db802a2507abb8ea5995b6ad8734c5dc7df8f3d2e8a96ed7ac970c68948946ee69ae3821ce39db987feb3dffdb37e54a10d9311d9b93c5
diff --git a/dev-ruby/nanotest/metadata.xml b/dev-ruby/nanotest/metadata.xml
new file mode 100644
index 000000000000..8484558cfc31
--- /dev/null
+++ b/dev-ruby/nanotest/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mynyml/nanotest</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/nanotest/nanotest-0.9.4.1.ebuild b/dev-ruby/nanotest/nanotest-0.9.4.1.ebuild
new file mode 100644
index 000000000000..52b03ad3f660
--- /dev/null
+++ b/dev-ruby/nanotest/nanotest-0.9.4.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Extremely mynymal test framework"
+HOMEPAGE="https://github.com/mynyml/nanotest"
+LICENSE="MIT"
+
+KEYWORDS="alpha amd64 arm ~arm64 ~hppa ia64 ppc ppc64 sparc x86"
+SLOT="0"
+IUSE=""
+
+each_ruby_test() {
+ ${RUBY} -I.:lib test/test_nanotest.rb || die
+}