summaryrefslogtreecommitdiff
path: root/dev-ruby/introspection
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-16 12:24:20 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-16 12:24:20 +0000
commite4ad5901ca8464ae513bd315a1c0349c2bd0986c (patch)
treec7b76ee1c59f8acf3eb9bd3112008b9ad8fd25fc /dev-ruby/introspection
parentf3784aee1f8e4d7971fd27543cb7490cb9f83649 (diff)
gentoo auto-resync : 16:03:2023 - 12:24:20
Diffstat (limited to 'dev-ruby/introspection')
-rw-r--r--dev-ruby/introspection/Manifest1
-rw-r--r--dev-ruby/introspection/introspection-0.0.4-r2.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/introspection/Manifest b/dev-ruby/introspection/Manifest
index 822ac1068b45..f0e9d45a8cf4 100644
--- a/dev-ruby/introspection/Manifest
+++ b/dev-ruby/introspection/Manifest
@@ -1,3 +1,4 @@
DIST introspection-0.0.4.gem 9216 BLAKE2B c97279576a60dfd74453d16a6eb0885326dad18748bd182fe3b5c2a73121553cd3ea66690841df6554fd105e50f5f6df075afb94795b94dbd7caf4615ca67764 SHA512 c228827ac9d8a82a104e78daadf038c674cd464bf726fc3bd1efa82e9d9cab37f6ee909f578585e7846378f0b755ed4d60fa119fd699f6c40188ea2de4ac7084
EBUILD introspection-0.0.4-r1.ebuild 681 BLAKE2B 18c2321b396fdacc68846c791194ae0150d1f9b7d8fa02146139ced188d6ad3f3d5aad118d42c6f0a15dca2b8dab1b084c37500cf96e3add47af3e36f11d1497 SHA512 377738711f0915fb072875d1bcbc44c16173b4bd3a71cba3d6e4917d9662f499ce6e7c4d325631e1c59f7f67d8d23ebc5182861c4b33f3af19cc004559839e71
+EBUILD introspection-0.0.4-r2.ebuild 689 BLAKE2B e26401500d84bd7edb62826c0bcc99bfe8adf142fbcc1bf889786b3a60bae59cad9c5be5a6e489268dbae1c2138a008b644bed0c60fa81d6428c963a5037a02e SHA512 e1e5f39c6cc62b1aaf856383183c6d4d13284d508ef41ebebe804b2e37fb3b2016d2225b5f36584b83b00d671b40e63f04bac75a53e28d01efd0ef2f1fddefa7
MISC metadata.xml 248 BLAKE2B 0c876bde3c72e61d28284a95a837103e6d594c9f6fccbd6d7d1039f9c5a604347c20c334c9a57d80b152888fed536196f2807b477e8d0336c80affb0e28c9dc9 SHA512 b2b64178cf6cbbaa5fb4671ffe1ab88b83c920de363ae099ef74fa3e5eb8c8f0285c749cabc0cebf344951503d1b7309ae294afe9e7cf5172700182d8843fa14
diff --git a/dev-ruby/introspection/introspection-0.0.4-r2.ebuild b/dev-ruby/introspection/introspection-0.0.4-r2.ebuild
new file mode 100644
index 000000000000..9539a60f5f90
--- /dev/null
+++ b/dev-ruby/introspection/introspection-0.0.4-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+
+# No documentation task
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Dynamic inspection of the hierarchy of method definitions on a Ruby object"
+HOMEPAGE="https://jamesmead.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/metaclass-0.0.1"
+
+ruby_add_bdepend "test? ( dev-ruby/blankslate )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/I s:^:#:' Rakefile test/test_helper.rb || die
+}