summaryrefslogtreecommitdiff
path: root/dev-ruby/introspection/introspection-0.0.4-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/introspection/introspection-0.0.4-r2.ebuild')
-rw-r--r--dev-ruby/introspection/introspection-0.0.4-r2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/introspection/introspection-0.0.4-r2.ebuild b/dev-ruby/introspection/introspection-0.0.4-r2.ebuild
new file mode 100644
index 000000000000..9539a60f5f90
--- /dev/null
+++ b/dev-ruby/introspection/introspection-0.0.4-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+
+# No documentation task
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Dynamic inspection of the hierarchy of method definitions on a Ruby object"
+HOMEPAGE="https://jamesmead.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/metaclass-0.0.1"
+
+ruby_add_bdepend "test? ( dev-ruby/blankslate )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/I s:^:#:' Rakefile test/test_helper.rb || die
+}