summaryrefslogtreecommitdiff
path: root/dev-ruby/http_parser_rb
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-27 14:54:15 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-27 14:54:15 +0100
commitd654bb059f90c086625a31ce15747f8418cd4bd5 (patch)
tree0a78e925021da9dc8bfd06ada53004c160b957b3 /dev-ruby/http_parser_rb
parent4e6378ddac49b7268b7ab55d1f5900b2a6d81923 (diff)
gentoo auto-resync : 27:08:2022 - 14:54:15
Diffstat (limited to 'dev-ruby/http_parser_rb')
-rw-r--r--dev-ruby/http_parser_rb/Manifest4
-rw-r--r--dev-ruby/http_parser_rb/http_parser_rb-0.8.0.ebuild29
-rw-r--r--dev-ruby/http_parser_rb/metadata.xml1
3 files changed, 33 insertions, 1 deletions
diff --git a/dev-ruby/http_parser_rb/Manifest b/dev-ruby/http_parser_rb/Manifest
index c470c7155a2f..cbbb59a0651e 100644
--- a/dev-ruby/http_parser_rb/Manifest
+++ b/dev-ruby/http_parser_rb/Manifest
@@ -1,3 +1,5 @@
DIST http_parser.rb-0.6.0.gem 177664 BLAKE2B ecae9e862454584759cbb3158eb16dd6de09fe95c6b38099f1c6d4be2376ca1d3eb8a6713994da600c9c567193466da30f4784652e19ad796891a53d67578fff SHA512 51c29bfc85de8cedb4e98fec84c955252556abaa4d0848fbc38b232879ffc946c72acf38440e8e9f1e31a8b734a68d43a96924af5f48ac4f1a054153ec913a08
+DIST http_parser.rb-0.8.0.gem 195072 BLAKE2B e02fa70e5f5219d70c887db47541985b07f938bb32c4cca943a3d50f73e3baf820a733a2f479f5d40a2e1dabda4d8ae2466834c8b6d8167646a8fb6dcf7c792b SHA512 228e8a617154411c43a548f10d2d8d2cae2d97970f621b4ef2955de94ed1943611cff22659cd75d63a09a0a02396993ab646ee29303d99856b46a80253a618c8
EBUILD http_parser_rb-0.6.0-r2.ebuild 705 BLAKE2B 2bedd1e7cac4fa9129bcb49457f0cf6ea294b1fbd017482aa483cd2a3541d2220e7caeb4e207d039a32c5f774b96ee130734172a22b0884892df126f68e9c8b4 SHA512 4096a3997be08dfb0987aeef363e9a5a5b8ad8d77fe254693b953c6c97b7bd63b840a4b4735584ea50d0022822e2e5c65bd66b5e34346390bee539e3c15747ca
-MISC metadata.xml 346 BLAKE2B 5169aa2eacb36006a706985194bb349b880218b8c3afc90562bb91cab866af9561b1e72059521f620655eb1e7043d9fcc1184803b14a6283b28c31f17ab39f4d SHA512 0ef4e4755e5bfe794e212752ebd76b1251597edce300f8fc3ff731cb8774418ed2fafb6ba3444a7ea266910d9bd4ed04ef08b07a3d97eaf7b120f01f3c01e129
+EBUILD http_parser_rb-0.8.0.ebuild 700 BLAKE2B 75ffe0cbfccbe66d041705102f6ceebdbe3a3879d3c717fcc2e10b25dee925941dc1ced02c1d760d48e9e2ddac1d95431ce0b7ff5b4babb18cf59867f1b9bb07 SHA512 c37f6c3c5fec873b8232cbc0096d0a3992e4ab52f8f2fd06c8b0fc344933145e8a4d1963f03b0e71c39f8152f5019732c6536aa6de61f18000ae5dd330d32b92
+MISC metadata.xml 404 BLAKE2B 481630df871022b629ea310953067db835dedf65e19a87a59a544803a4f92524c9a7f69573e0097c289d000372188e935e05a30b36644cbff1d6a138a40c9e06 SHA512 4c87ca0f78e606e56b8ae8fd1f9f41dd1d26edd70f27f891a25d1c70d92bd53b4b80512e04647565c8ea5e478eb996e32efcb1dd9ba47fb750d7b024d54bbc19
diff --git a/dev-ruby/http_parser_rb/http_parser_rb-0.8.0.ebuild b/dev-ruby/http_parser_rb/http_parser_rb-0.8.0.ebuild
new file mode 100644
index 000000000000..d00c5f9020cd
--- /dev/null
+++ b/dev-ruby/http_parser_rb/http_parser_rb-0.8.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_NAME="http_parser.rb"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/ruby_http_parser/extconf.rb)
+
+inherit ruby-fakegem
+
+DESCRIPTION="Simple callback-based HTTP request/response parser"
+HOMEPAGE="https://github.com/tmm1/http_parser.rb"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ # rspec 3 compatibility
+ sed -i -e 's/be_true/be true/; s/be_false/be false/' spec/parser_spec.rb || die
+}
diff --git a/dev-ruby/http_parser_rb/metadata.xml b/dev-ruby/http_parser_rb/metadata.xml
index 28c8973fca91..63061c24ff42 100644
--- a/dev-ruby/http_parser_rb/metadata.xml
+++ b/dev-ruby/http_parser_rb/metadata.xml
@@ -7,5 +7,6 @@
</maintainer>
<upstream>
<remote-id type="github">tmm1/http_parser.rb</remote-id>
+ <remote-id type="rubygems">http_parser.rb</remote-id>
</upstream>
</pkgmetadata>