summaryrefslogtreecommitdiff
path: root/dev-ruby/http_parser_rb/http_parser_rb-0.8.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/http_parser_rb/http_parser_rb-0.8.0.ebuild')
-rw-r--r--dev-ruby/http_parser_rb/http_parser_rb-0.8.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/http_parser_rb/http_parser_rb-0.8.0.ebuild b/dev-ruby/http_parser_rb/http_parser_rb-0.8.0.ebuild
new file mode 100644
index 000000000000..d00c5f9020cd
--- /dev/null
+++ b/dev-ruby/http_parser_rb/http_parser_rb-0.8.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_NAME="http_parser.rb"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/ruby_http_parser/extconf.rb)
+
+inherit ruby-fakegem
+
+DESCRIPTION="Simple callback-based HTTP request/response parser"
+HOMEPAGE="https://github.com/tmm1/http_parser.rb"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ # rspec 3 compatibility
+ sed -i -e 's/be_true/be true/; s/be_false/be false/' spec/parser_spec.rb || die
+}