summaryrefslogtreecommitdiff
path: root/dev-ruby/heredoc_unindent/heredoc_unindent-1.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/heredoc_unindent/heredoc_unindent-1.2.0.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/heredoc_unindent/heredoc_unindent-1.2.0.ebuild')
-rw-r--r--dev-ruby/heredoc_unindent/heredoc_unindent-1.2.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ruby/heredoc_unindent/heredoc_unindent-1.2.0.ebuild b/dev-ruby/heredoc_unindent/heredoc_unindent-1.2.0.ebuild
new file mode 100644
index 000000000000..3697dee1b3e1
--- /dev/null
+++ b/dev-ruby/heredoc_unindent/heredoc_unindent-1.2.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+inherit ruby-fakegem
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc History.rdoc"
+DESCRIPTION="Removes leading whitespace from Ruby heredocs"
+HOMEPAGE="https://github.com/adrianomitre/heredoc_unindent"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 x86 ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_bdepend "test? ( >=dev-ruby/hoe-2.8.0 dev-ruby/test-unit:2 )"
+
+all_ruby_prepare() {
+ sed -i -e '1igem "test-unit"' test/test_heredoc_unindent.rb || die
+}