summaryrefslogtreecommitdiff
path: root/dev-ruby/heredoc_unindent
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/heredoc_unindent
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/heredoc_unindent')
-rw-r--r--dev-ruby/heredoc_unindent/Manifest3
-rw-r--r--dev-ruby/heredoc_unindent/heredoc_unindent-1.2.0.ebuild24
-rw-r--r--dev-ruby/heredoc_unindent/metadata.xml11
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-ruby/heredoc_unindent/Manifest b/dev-ruby/heredoc_unindent/Manifest
new file mode 100644
index 000000000000..b4da95b99c2b
--- /dev/null
+++ b/dev-ruby/heredoc_unindent/Manifest
@@ -0,0 +1,3 @@
+DIST heredoc_unindent-1.2.0.gem 10240 BLAKE2B 2d29e85e03b4da87277e82ad3c7f85f8c4f4063651a5e1aa9931ae257c8e3416b6feb6403ee158b2fb6bd4bb0b6fcf00a09bf688b3ba3acc76b5000639a7c248 SHA512 a975ffdc2ae3716a7fb90145270df03d6f3d45d42d3fca3125044a2b960a9c8ffc74a7fb0e315b6021cb6ce535b08207a40351573ed89c27fe0c8e196ea02c76
+EBUILD heredoc_unindent-1.2.0.ebuild 735 BLAKE2B bb50376d4b21700ec72a662d9a3d770e4d47bea454848a725e2f974fcb0d4f0ee69da4619b10d92f095d893e439edd56806412b1a738dc6f3d14671415eab863 SHA512 e0bda314f7ba2f5eecfcbca7f91c91f456dd64981dc0a9165f6ec6a74d78dbdbfd4502aabd61e6d5b4019e6f9aef7826cbe30986a2328e14b4d10ff55c4f6c12
+MISC metadata.xml 355 BLAKE2B d6f3b21bb4e87e3eba58668a666a27da2fba665c0c96595b438564fca3fc691be1f8a5335175295617a18b3a77ec0966db5d9304de89859af6bdafc301379739 SHA512 bf551d4c3b25ce65b832a8d23fa0d333a79fff8b0681e975cb237367f0470fde3ee8a37f3df81d292915ece3a0bea6246de190880889d0f739870e106ec36978
diff --git a/dev-ruby/heredoc_unindent/heredoc_unindent-1.2.0.ebuild b/dev-ruby/heredoc_unindent/heredoc_unindent-1.2.0.ebuild
new file mode 100644
index 000000000000..3697dee1b3e1
--- /dev/null
+++ b/dev-ruby/heredoc_unindent/heredoc_unindent-1.2.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+inherit ruby-fakegem
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc History.rdoc"
+DESCRIPTION="Removes leading whitespace from Ruby heredocs"
+HOMEPAGE="https://github.com/adrianomitre/heredoc_unindent"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 x86 ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_bdepend "test? ( >=dev-ruby/hoe-2.8.0 dev-ruby/test-unit:2 )"
+
+all_ruby_prepare() {
+ sed -i -e '1igem "test-unit"' test/test_heredoc_unindent.rb || die
+}
diff --git a/dev-ruby/heredoc_unindent/metadata.xml b/dev-ruby/heredoc_unindent/metadata.xml
new file mode 100644
index 000000000000..4f31c842ccfc
--- /dev/null
+++ b/dev-ruby/heredoc_unindent/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">adrianomitre/heredoc_unindent</remote-id>
+ </upstream>
+</pkgmetadata>