summaryrefslogtreecommitdiff
path: root/dev-ruby/haml/haml-6.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-13 11:48:35 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-13 11:48:35 +0000
commite45f0df9d7f9f5260e69235b8c7c6e00153747f0 (patch)
tree1999e441fd73f9d62d9ab632067bb978b9b34f29 /dev-ruby/haml/haml-6.1.1.ebuild
parent4bc834b03b9438dcfd45780f31a02994c24608ba (diff)
gentoo auto-resync : 13:01:2023 - 11:48:35
Diffstat (limited to 'dev-ruby/haml/haml-6.1.1.ebuild')
-rw-r--r--dev-ruby/haml/haml-6.1.1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/dev-ruby/haml/haml-6.1.1.ebuild b/dev-ruby/haml/haml-6.1.1.ebuild
new file mode 100644
index 000000000000..1bd1fbf34089
--- /dev/null
+++ b/dev-ruby/haml/haml-6.1.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTENSIONS=(ext/haml/extconf.rb)
+RUBY_FAKEGEM_EXTENSION_LIBDIR="lib/haml"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md FAQ.md README.md REFERENCE.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A ruby web page templating engine"
+HOMEPAGE="https://haml.info/"
+SRC_URI="https://github.com/haml/haml/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+IUSE="doc test"
+
+ruby_add_rdepend ">=dev-ruby/temple-0.8.2 dev-ruby/thor dev-ruby/tilt:*"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/minitest:5
+ dev-ruby/nokogiri
+ >=dev-ruby/railties-6.0
+ >=dev-ruby/activemodel-6.0
+ >=dev-ruby/actionpack-6.0
+ )
+ doc? (
+ dev-ruby/yard
+ )"
+
+all_ruby_prepare() {
+ sed -i -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ sed -i -e '/bundler/ s:^:#: ; /Bundler/,/end/ s:^:#:' Rakefile || die
+ sed -i -e '/bundler/I s:^:#:' \
+ -e '/simplecov/I s:^:#:' \
+ test/test_helper.rb || die
+ # Remove tests that fails when RedCloth is available
+ rm -f test/haml/filters/markdown_test.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test:. -rtest_helper -e 'Dir["test/haml/**/*_test.rb"].each { require _1 }' || die
+}