summaryrefslogtreecommitdiff
path: root/dev-ruby/haml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-13 11:48:35 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-13 11:48:35 +0000
commite45f0df9d7f9f5260e69235b8c7c6e00153747f0 (patch)
tree1999e441fd73f9d62d9ab632067bb978b9b34f29 /dev-ruby/haml
parent4bc834b03b9438dcfd45780f31a02994c24608ba (diff)
gentoo auto-resync : 13:01:2023 - 11:48:35
Diffstat (limited to 'dev-ruby/haml')
-rw-r--r--dev-ruby/haml/Manifest4
-rw-r--r--dev-ruby/haml/haml-6.1.1.ebuild55
-rw-r--r--dev-ruby/haml/metadata.xml12
3 files changed, 66 insertions, 5 deletions
diff --git a/dev-ruby/haml/Manifest b/dev-ruby/haml/Manifest
index cf81eed4e2e7..e665f0c5ff33 100644
--- a/dev-ruby/haml/Manifest
+++ b/dev-ruby/haml/Manifest
@@ -1,3 +1,5 @@
DIST haml-5.2.2.tar.gz 129833 BLAKE2B d68c24c7a3c817d6d364b2ec92b84b4f56f4fffa48b99d17b2df27da35f50b1fb1f69b184a7b21d899c476e0d4c8ad2b940a7cb2995ec24ecdafab8ef61fe393 SHA512 1aec59fab20d8139a5dfedde2007fa8137a377a345e4d30229f9d1140d56cdf970c8ae70e2647e6a408d7fa543a16050f66a8a636efa6a6b1f91ee1ffcc136c1
+DIST haml-6.1.1.tar.gz 669644 BLAKE2B 239b3a1fe02bcd1e2981198ba7c54c71ca2af0947102fcea6cd600cc6579294856baa290589a7d3a015e54df8bcecf8e50175cf2189e8f4f9c6f9721a558bcc9 SHA512 7d732be085b41b8f0eec418600a82b51c68301081165aa636fa342ae26b74215a202a4b15e592da980d9a7fbe24bad01399f599770420133c4b6ab7523386fa5
EBUILD haml-5.2.2.ebuild 1496 BLAKE2B 1abadf57965798595ed08da1de7b19b0635a05ead6287e29e8902c2a69de9a69b693d3e282ba51468f6ed4c83a455c63f539020274c4e8332f8e933dec8d233c SHA512 3828bbbf977f0157e3669c425b870b8faff8260c94be80b3f08b55c04b2654a763e24f0b82d6dd4deb79075f0d85741e34462aa020903f01dc0c3c5f4eb43d4a
-MISC metadata.xml 248 BLAKE2B 0c876bde3c72e61d28284a95a837103e6d594c9f6fccbd6d7d1039f9c5a604347c20c334c9a57d80b152888fed536196f2807b477e8d0336c80affb0e28c9dc9 SHA512 b2b64178cf6cbbaa5fb4671ffe1ab88b83c920de363ae099ef74fa3e5eb8c8f0285c749cabc0cebf344951503d1b7309ae294afe9e7cf5172700182d8843fa14
+EBUILD haml-6.1.1.ebuild 1503 BLAKE2B 0a8bd32d1ec14e23757a956376fb9e6014ae2853d0454b15dbcb9a5dc57f58fce9d97a99a5a75997961c5c67314984dbbb60a5799477f21d1945efae74c5f98f SHA512 528c1fcd88bb67620771a179557716963cbef7b35cb1e242340e85aa81902daf3f9bd7a29721aff0e2a23dcc3f81ad825ba4db8c9bdaafe3f3ca5f3d0979b18b
+MISC metadata.xml 384 BLAKE2B 49a1ec969b1de2c61646aef404bcb19961d7f7b6b8c0324c1f447c8847adb0d3667e653b4273ed1c7e177e7e5216e6275a7c664ee6917ecb48e69d89554a33c6 SHA512 047f50785afcb708d07a770c38e40d7c8be01455832f01bbd006608eb18af8a8470a21ab0c57b7304ad4e2be39121310d0feb1ac64163a1b5e4c1cbf61cb8bfb
diff --git a/dev-ruby/haml/haml-6.1.1.ebuild b/dev-ruby/haml/haml-6.1.1.ebuild
new file mode 100644
index 000000000000..1bd1fbf34089
--- /dev/null
+++ b/dev-ruby/haml/haml-6.1.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTENSIONS=(ext/haml/extconf.rb)
+RUBY_FAKEGEM_EXTENSION_LIBDIR="lib/haml"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md FAQ.md README.md REFERENCE.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A ruby web page templating engine"
+HOMEPAGE="https://haml.info/"
+SRC_URI="https://github.com/haml/haml/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+IUSE="doc test"
+
+ruby_add_rdepend ">=dev-ruby/temple-0.8.2 dev-ruby/thor dev-ruby/tilt:*"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/minitest:5
+ dev-ruby/nokogiri
+ >=dev-ruby/railties-6.0
+ >=dev-ruby/activemodel-6.0
+ >=dev-ruby/actionpack-6.0
+ )
+ doc? (
+ dev-ruby/yard
+ )"
+
+all_ruby_prepare() {
+ sed -i -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ sed -i -e '/bundler/ s:^:#: ; /Bundler/,/end/ s:^:#:' Rakefile || die
+ sed -i -e '/bundler/I s:^:#:' \
+ -e '/simplecov/I s:^:#:' \
+ test/test_helper.rb || die
+ # Remove tests that fails when RedCloth is available
+ rm -f test/haml/filters/markdown_test.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test:. -rtest_helper -e 'Dir["test/haml/**/*_test.rb"].each { require _1 }' || die
+}
diff --git a/dev-ruby/haml/metadata.xml b/dev-ruby/haml/metadata.xml
index 658c72b1920d..81aca44931d3 100644
--- a/dev-ruby/haml/metadata.xml
+++ b/dev-ruby/haml/metadata.xml
@@ -1,8 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="project">
- <email>ruby@gentoo.org</email>
- <name>Gentoo Ruby Project</name>
-</maintainer>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">haml/haml</remote-id>
+ <remote-id type="rubygems">haml</remote-id>
+ </upstream>
</pkgmetadata>