summaryrefslogtreecommitdiff
path: root/dev-ruby/commander
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-25 11:50:47 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-25 11:50:47 +0000
commitd42200bec37eef2a7478d88988ff00addd0a9202 (patch)
tree10394660b3cbe4b50173c06950b31302cd25d0d1 /dev-ruby/commander
parent580f05ea8f512d11e23e8da80177d27835cbdbbc (diff)
gentoo resync : 25.01.2020
Diffstat (limited to 'dev-ruby/commander')
-rw-r--r--dev-ruby/commander/commander-4.5.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ruby/commander/commander-4.5.0.ebuild b/dev-ruby/commander/commander-4.5.0.ebuild
new file mode 100644
index 000000000000..70c03572a57f
--- /dev/null
+++ b/dev-ruby/commander/commander-4.5.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_EXTRADOC="History.rdoc README.md"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="The complete solution for Ruby command-line executables"
+HOMEPAGE="https://visionmedia.github.com/commander/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/highline:2"
+
+all_ruby_prepare() {
+ sed -i -e "/simplecov/,/end/ s:^:#:" spec/spec_helper.rb || die
+}