summaryrefslogtreecommitdiff
path: root/dev-ruby/commander/commander-4.5.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/commander/commander-4.5.0.ebuild')
-rw-r--r--dev-ruby/commander/commander-4.5.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ruby/commander/commander-4.5.0.ebuild b/dev-ruby/commander/commander-4.5.0.ebuild
new file mode 100644
index 000000000000..70c03572a57f
--- /dev/null
+++ b/dev-ruby/commander/commander-4.5.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_EXTRADOC="History.rdoc README.md"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="The complete solution for Ruby command-line executables"
+HOMEPAGE="https://visionmedia.github.com/commander/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/highline:2"
+
+all_ruby_prepare() {
+ sed -i -e "/simplecov/,/end/ s:^:#:" spec/spec_helper.rb || die
+}