summaryrefslogtreecommitdiff
path: root/dev-ros/tf2_kdl/tf2_kdl-0.7.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /dev-ros/tf2_kdl/tf2_kdl-0.7.5.ebuild
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'dev-ros/tf2_kdl/tf2_kdl-0.7.5.ebuild')
-rw-r--r--dev-ros/tf2_kdl/tf2_kdl-0.7.5.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ros/tf2_kdl/tf2_kdl-0.7.5.ebuild b/dev-ros/tf2_kdl/tf2_kdl-0.7.5.ebuild
new file mode 100644
index 000000000000..91b549006511
--- /dev/null
+++ b/dev-ros/tf2_kdl/tf2_kdl-0.7.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros/geometry2"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="KDL binding for tf2"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/tf2
+ dev-ros/tf2_ros
+ $(python_gen_cond_dep "dev-python/python_orocos_kdl[\${PYTHON_USEDEP}]")
+ sci-libs/orocos_kdl:=
+ dev-ros/tf2_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-ros/cmake_modules
+ dev-cpp/eigen:3
+ test? (
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ dev-cpp/gtest
+ )"