summaryrefslogtreecommitdiff
path: root/dev-ros/tf2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-07 18:44:07 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-07 18:44:07 +0000
commit5001a6c7b6da2956f5b17c695b1e0059dc7b8de5 (patch)
tree0528a53855a7ec96d20cde9edb9031aab030224c /dev-ros/tf2
parenta8b0d35ab742f31538d515dea39716e566d533c0 (diff)
gentoo resync : 07.01.2018
Diffstat (limited to 'dev-ros/tf2')
-rw-r--r--dev-ros/tf2/Manifest3
-rw-r--r--dev-ros/tf2/files/logging2.patch98
-rw-r--r--dev-ros/tf2/tf2-0.5.17.ebuild26
3 files changed, 127 insertions, 0 deletions
diff --git a/dev-ros/tf2/Manifest b/dev-ros/tf2/Manifest
index 5e2be73fea1b..63aa1004200e 100644
--- a/dev-ros/tf2/Manifest
+++ b/dev-ros/tf2/Manifest
@@ -1,5 +1,8 @@
AUX logging.patch 5541 BLAKE2B 8c9b0a8dbd252578a1937f94001dd6748f0f90e26a3124b59d8532937c8429509f7ee5eec282ea16f7b1da689ab915d5e7f453d97b2caf1192d51a325647bae3 SHA512 7eba7fac00a5ae57f248923fd7239b2bd5cfc1856ffcdcb945abc1c3bed47591019df5c74e8efb57069ce04d5d11f4a13f3a1184b1f08f9366028693eda85137
+AUX logging2.patch 5525 BLAKE2B 45b97190e37707666411200902ed91679e0ee84b97fc3f2b89da7f501e4e040a2c2d652ddcb3ef239b0c290b736214f58f23ac573fa899436570b617468052d6 SHA512 15bb8059c5d6f85b9ff8483140577bba05dff762c47e49fdadcba3f297381b74142118fa86bdbd0dae34e245cd24c6813ad8185ee51201022cad094a550523d4
DIST geometry2-0.5.16.tar.gz 154351 BLAKE2B e630be09da6de544de0215d40ffcb0aa780be253320264d52603d5fe7506d12b27e986acb9c036973ba390c5cd96b5e838849ee2f5b1399148cf5cffb461cd76 SHA512 11909db98af78bbdef8d1a7dc5f20d3ff3cfcb0afc0e1d53b97a1ffe99aecea911f09364593eb232d7514a4caa192141404d892a33fc7ea9f5ce924ecf99fc51
+DIST geometry2-0.5.17.tar.gz 156516 BLAKE2B 72f936086fe3dbcfa3c05f7ae72e64f20fd1525513e79ed9c4dae7c5b097501ea230c483a3f1eb6e0ba6a342e0ddc5deacf05ec9f0c97b56df48dcf2bf669e8b SHA512 44d91796f03d0cbd8a9247568827dca4a848ec931fa754fd7815e9102f7bcac38e85ebcc27e3037827358dbfbc7d58b28775f00e1e04c48125e56c7b97cde925
EBUILD tf2-0.5.16-r1.ebuild 590 BLAKE2B 32fee5598ef4a136435f6ec1f96bba9f0240715d25f8c9251718a409e7bccb7e1b3c193fc57373126678f3a6195ddffc544530d77196292c3c00c5f571dfff77 SHA512 05e9e783551bc5a9eb66f211ce1a1c452c1027f46b2abb47b7951a2eeb343fbe72fdb27fcb353f97fac9c11866b450499d5c059c062f4dfb8662c9a9f526bb17
+EBUILD tf2-0.5.17.ebuild 591 BLAKE2B dbc52be3548178d8d2117b1e72c561a78e9a0e50be6b84a52c71cb119f3f09fdbb76626e1448298c60b897651193ce2e40e7680ce70ff4331e1ff8c730042aaa SHA512 626f6abe2243cf11c4022efe086a259dee70fb8a56a08e0c8f50fc6166b7b461840262a277fe824970048eac3567e435f704f98d701f70c10a24e340c84a4ba0
EBUILD tf2-9999.ebuild 550 BLAKE2B 10c50cfb412755a1c9ca026c2343da67ebdd73a2d9b9eb3697d7d87ca3a167e7f02008cd1f55c6cea8129b162d32c0277ddadfe07dc814a8359e0366f4013121 SHA512 f90dce47cd2d78d2de07c1bfc8da8e17865fe4c3e76313efc8751be397e2892a4df61a10de60eb875309ae9db9c20cd6700a72540cbeb49e303a297d830281b4
MISC metadata.xml 339 BLAKE2B bf7648aaefd8e1834d8d0faf1307566a068bffc3873942b6c799124486a369df38f2defae61afb67c51ed4750b77ee68ab163d1510b6ea0dedb3867bfa9a29e2 SHA512 70bde02b98edb10a9340db05de2bac26828bafd43be3fe2796a4cc8c115b409eac13c0eecd0ecb038f49f6eaa2bd6588671afff450fef02c0301356323216d51
diff --git a/dev-ros/tf2/files/logging2.patch b/dev-ros/tf2/files/logging2.patch
new file mode 100644
index 000000000000..38a3ee3c0bb6
--- /dev/null
+++ b/dev-ros/tf2/files/logging2.patch
@@ -0,0 +1,98 @@
+Index: tf2/src/buffer_core.cpp
+===================================================================
+--- tf2.orig/src/buffer_core.cpp
++++ tf2/src/buffer_core.cpp
+@@ -123,7 +123,7 @@ bool BufferCore::warnFrameId(const char*
+ {
+ std::stringstream ss;
+ ss << "Invalid argument passed to "<< function_name_arg <<" in tf2 frame_ids cannot be empty";
+- logWarn("%s",ss.str().c_str());
++ CONSOLE_BRIDGE_logWarn("%s",ss.str().c_str());
+ return true;
+ }
+
+@@ -131,7 +131,7 @@ bool BufferCore::warnFrameId(const char*
+ {
+ std::stringstream ss;
+ ss << "Invalid argument \"" << frame_id << "\" passed to "<< function_name_arg <<" in tf2 frame_ids cannot start with a '/' like: ";
+- logWarn("%s",ss.str().c_str());
++ CONSOLE_BRIDGE_logWarn("%s",ss.str().c_str());
+ return true;
+ }
+
+@@ -218,26 +218,26 @@ bool BufferCore::setTransform(const geom
+ bool error_exists = false;
+ if (stripped.child_frame_id == stripped.header.frame_id)
+ {
+- logError("TF_SELF_TRANSFORM: Ignoring transform from authority \"%s\" with frame_id and child_frame_id \"%s\" because they are the same", authority.c_str(), stripped.child_frame_id.c_str());
++ CONSOLE_BRIDGE_logError("TF_SELF_TRANSFORM: Ignoring transform from authority \"%s\" with frame_id and child_frame_id \"%s\" because they are the same", authority.c_str(), stripped.child_frame_id.c_str());
+ error_exists = true;
+ }
+
+ if (stripped.child_frame_id == "")
+ {
+- logError("TF_NO_CHILD_FRAME_ID: Ignoring transform from authority \"%s\" because child_frame_id not set ", authority.c_str());
++ CONSOLE_BRIDGE_logError("TF_NO_CHILD_FRAME_ID: Ignoring transform from authority \"%s\" because child_frame_id not set ", authority.c_str());
+ error_exists = true;
+ }
+
+ if (stripped.header.frame_id == "")
+ {
+- logError("TF_NO_FRAME_ID: Ignoring transform with child_frame_id \"%s\" from authority \"%s\" because frame_id not set", stripped.child_frame_id.c_str(), authority.c_str());
++ CONSOLE_BRIDGE_logError("TF_NO_FRAME_ID: Ignoring transform with child_frame_id \"%s\" from authority \"%s\" because frame_id not set", stripped.child_frame_id.c_str(), authority.c_str());
+ error_exists = true;
+ }
+
+ if (std::isnan(stripped.transform.translation.x) || std::isnan(stripped.transform.translation.y) || std::isnan(stripped.transform.translation.z)||
+ std::isnan(stripped.transform.rotation.x) || std::isnan(stripped.transform.rotation.y) || std::isnan(stripped.transform.rotation.z) || std::isnan(stripped.transform.rotation.w))
+ {
+- logError("TF_NAN_INPUT: Ignoring transform for child_frame_id \"%s\" from authority \"%s\" because of a nan value in the transform (%f %f %f) (%f %f %f %f)",
++ CONSOLE_BRIDGE_logError("TF_NAN_INPUT: Ignoring transform for child_frame_id \"%s\" from authority \"%s\" because of a nan value in the transform (%f %f %f) (%f %f %f %f)",
+ stripped.child_frame_id.c_str(), authority.c_str(),
+ stripped.transform.translation.x, stripped.transform.translation.y, stripped.transform.translation.z,
+ stripped.transform.rotation.x, stripped.transform.rotation.y, stripped.transform.rotation.z, stripped.transform.rotation.w
+@@ -252,7 +252,7 @@ bool BufferCore::setTransform(const geom
+
+ if (!valid)
+ {
+- logError("TF_DENORMALIZED_QUATERNION: Ignoring transform for child_frame_id \"%s\" from authority \"%s\" because of an invalid quaternion in the transform (%f %f %f %f)",
++ CONSOLE_BRIDGE_logError("TF_DENORMALIZED_QUATERNION: Ignoring transform for child_frame_id \"%s\" from authority \"%s\" because of an invalid quaternion in the transform (%f %f %f %f)",
+ stripped.child_frame_id.c_str(), authority.c_str(),
+ stripped.transform.rotation.x, stripped.transform.rotation.y, stripped.transform.rotation.z, stripped.transform.rotation.w);
+ error_exists = true;
+@@ -274,7 +274,7 @@ bool BufferCore::setTransform(const geom
+ }
+ else
+ {
+- logWarn("TF_OLD_DATA ignoring data from the past for frame %s at time %g according to authority %s\nPossible reasons are listed at http://wiki.ros.org/tf/Errors%%20explained", stripped.child_frame_id.c_str(), stripped.header.stamp.toSec(), authority.c_str());
++ CONSOLE_BRIDGE_logWarn("TF_OLD_DATA ignoring data from the past for frame %s at time %g according to authority %s\nPossible reasons are listed at http://wiki.ros.org/tf/Errors%%20explained", stripped.child_frame_id.c_str(), stripped.header.stamp.toSec(), authority.c_str());
+ return false;
+ }
+ }
+@@ -633,7 +633,7 @@ geometry_msgs::TransformStamped BufferCo
+ case tf2_msgs::TF2Error::LOOKUP_ERROR:
+ throw LookupException(error_string);
+ default:
+- logError("Unknown error code: %d", retval);
++ CONSOLE_BRIDGE_logError("Unknown error code: %d", retval);
+ assert(0);
+ }
+ }
+@@ -1604,7 +1604,7 @@ void BufferCore::_chainAsVector(const st
+ case tf2_msgs::TF2Error::LOOKUP_ERROR:
+ throw LookupException(error_string);
+ default:
+- logError("Unknown error code: %d", retval);
++ CONSOLE_BRIDGE_logError("Unknown error code: %d", retval);
+ assert(0);
+ }
+ }
+@@ -1623,7 +1623,7 @@ void BufferCore::_chainAsVector(const st
+ case tf2_msgs::TF2Error::LOOKUP_ERROR:
+ throw LookupException(error_string);
+ default:
+- logError("Unknown error code: %d", retval);
++ CONSOLE_BRIDGE_logError("Unknown error code: %d", retval);
+ assert(0);
+ }
+ }
diff --git a/dev-ros/tf2/tf2-0.5.17.ebuild b/dev-ros/tf2/tf2-0.5.17.ebuild
new file mode 100644
index 000000000000..775ef1258bc2
--- /dev/null
+++ b/dev-ros/tf2/tf2-0.5.17.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/geometry2"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="The second generation Transform Library in ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/tf2_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-libs/console_bridge:=
+ dev-ros/rostime
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-libs/boost:=[threads]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/roscpp )
+"
+PATCHES=( "${FILESDIR}/logging2.patch" )