summaryrefslogtreecommitdiff
path: root/dev-ros/tf2/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-19 22:05:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-19 22:05:27 +0100
commit121ed4eec41fbf03e1998d09eede1bf449da63b9 (patch)
treece9341d77d1507f67d4a3a1472da9011b5baa0a8 /dev-ros/tf2/files
parentdd762ff83c330186ee2ede002e08b2f780cddd51 (diff)
gentoo resync : 19.07.2019
Diffstat (limited to 'dev-ros/tf2/files')
-rw-r--r--dev-ros/tf2/files/boost.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ros/tf2/files/boost.patch b/dev-ros/tf2/files/boost.patch
new file mode 100644
index 000000000000..5f87149ee31e
--- /dev/null
+++ b/dev-ros/tf2/files/boost.patch
@@ -0,0 +1,26 @@
+commit 6223549e4d5e1d442a9cfb8e8c7334bcc62c1662
+Author: Maarten de Vries <maarten@de-vri.es>
+Date: Thu Jan 17 16:00:14 2019 +0100
+
+ Remove `signals` from find_package(Boost COMPONENTS ...).
+
+ tf2 is using signals2, which is not the same library.
+ Additionally, signals2 has always been header only, and header only
+ libraries must not be listed in find_package.
+
+ Boost 1.69 removed the old signals library entirely, so the otherwise
+ useless `COMPONENTS signals` actually breaks the build.
+
+diff --git a/tf2/CMakeLists.txt b/tf2/CMakeLists.txt
+index 9ffb17a..7a6da34 100644
+--- a/tf2/CMakeLists.txt
++++ b/tf2/CMakeLists.txt
+@@ -3,7 +3,7 @@ project(tf2)
+
+ find_package(console_bridge REQUIRED)
+ find_package(catkin REQUIRED COMPONENTS geometry_msgs rostime tf2_msgs)
+-find_package(Boost REQUIRED COMPONENTS signals system thread)
++find_package(Boost REQUIRED COMPONENTS system thread)
+
+ catkin_package(
+ INCLUDE_DIRS include