summaryrefslogtreecommitdiff
path: root/dev-ros/test_tf2/test_tf2-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ros/test_tf2/test_tf2-9999.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ros/test_tf2/test_tf2-9999.ebuild')
-rw-r--r--dev-ros/test_tf2/test_tf2-9999.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ros/test_tf2/test_tf2-9999.ebuild b/dev-ros/test_tf2/test_tf2-9999.ebuild
new file mode 100644
index 000000000000..4378c07e804e
--- /dev/null
+++ b/dev-ros/test_tf2/test_tf2-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/geometry2"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="TF2 unit tests"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/tf
+ dev-ros/tf2
+ dev-ros/tf2_bullet
+ dev-ros/tf2_ros[${PYTHON_USEDEP}]
+ dev-ros/tf2_geometry_msgs[${PYTHON_USEDEP}]
+ dev-ros/tf2_kdl[${PYTHON_USEDEP}]
+ dev-ros/tf2_msgs
+ sci-libs/orocos_kdl
+ dev-python/python_orocos_kdl[${PYTHON_USEDEP}]
+ dev-libs/boost:=[threads]
+ dev-cpp/gtest"
+
+mycatkincmakeargs=( "-DCATKIN_ENABLE_TESTING=ON" )