summaryrefslogtreecommitdiff
path: root/dev-ros/test_rosgraph/test_rosgraph-1.15.11.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-07 00:16:33 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-07 00:16:33 +0100
commitd162ba1860a88062f4cd61f8b52fc303ba0b2991 (patch)
tree24cd2cf57f3932a24b96e4a0f6666489447e43ba /dev-ros/test_rosgraph/test_rosgraph-1.15.11.ebuild
parent590b9b7b03bf4651e099949e318755af7cfa81b8 (diff)
gentoo resync : 07.08.2021
Diffstat (limited to 'dev-ros/test_rosgraph/test_rosgraph-1.15.11.ebuild')
-rw-r--r--dev-ros/test_rosgraph/test_rosgraph-1.15.11.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/test_rosgraph/test_rosgraph-1.15.11.ebuild b/dev-ros/test_rosgraph/test_rosgraph-1.15.11.ebuild
new file mode 100644
index 000000000000..63863b4ad56b
--- /dev/null
+++ b/dev-ros/test_rosgraph/test_rosgraph-1.15.11.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for rosgraph"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rosgraph[${PYTHON_SINGLE_USEDEP}] )
+"
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_test
+}