summaryrefslogtreecommitdiff
path: root/dev-ros/test_diagnostic_aggregator/test_diagnostic_aggregator-1.9.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-11 16:02:49 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-11 16:02:49 +0100
commit88ebe56470c37b02a044e1091cad6b2df0f3be8f (patch)
treed80b2d9337c01c4a0fe11a2ef9691fc3153ed6d3 /dev-ros/test_diagnostic_aggregator/test_diagnostic_aggregator-1.9.3.ebuild
parent4645b6f17f0da81e9fe84081fb126a37102ba153 (diff)
gentoo resync : 11.05.2018
Diffstat (limited to 'dev-ros/test_diagnostic_aggregator/test_diagnostic_aggregator-1.9.3.ebuild')
-rw-r--r--dev-ros/test_diagnostic_aggregator/test_diagnostic_aggregator-1.9.3.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/test_diagnostic_aggregator/test_diagnostic_aggregator-1.9.3.ebuild b/dev-ros/test_diagnostic_aggregator/test_diagnostic_aggregator-1.9.3.ebuild
new file mode 100644
index 000000000000..cabd94dbe35a
--- /dev/null
+++ b/dev-ros/test_diagnostic_aggregator/test_diagnostic_aggregator-1.9.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/diagnostics"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="diagnostic_aggregator tests"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/diagnostic_aggregator
+ dev-ros/diagnostic_msgs
+ dev-ros/pluginlib
+ dev-ros/roscpp
+ dev-ros/rospy
+ dev-ros/rostest
+"
+DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/gcc6.patch" )