summaryrefslogtreecommitdiff
path: root/dev-ros/rqt_pose_view/rqt_pose_view-0.5.11.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-07 00:16:33 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-07 00:16:33 +0100
commitd162ba1860a88062f4cd61f8b52fc303ba0b2991 (patch)
tree24cd2cf57f3932a24b96e4a0f6666489447e43ba /dev-ros/rqt_pose_view/rqt_pose_view-0.5.11.ebuild
parent590b9b7b03bf4651e099949e318755af7cfa81b8 (diff)
gentoo resync : 07.08.2021
Diffstat (limited to 'dev-ros/rqt_pose_view/rqt_pose_view-0.5.11.ebuild')
-rw-r--r--dev-ros/rqt_pose_view/rqt_pose_view-0.5.11.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ros/rqt_pose_view/rqt_pose_view-0.5.11.ebuild b/dev-ros/rqt_pose_view/rqt_pose_view-0.5.11.ebuild
new file mode 100644
index 000000000000..cd3b6a564f73
--- /dev/null
+++ b/dev-ros/rqt_pose_view/rqt_pose_view-0.5.11.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_pose_view"
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for visualizing 3D poses"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ $(python_gen_cond_dep "dev-python/pyopengl[\${PYTHON_USEDEP}]")
+ dev-ros/python_qt_binding[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep "dev-python/rospkg[\${PYTHON_USEDEP}]")
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rostopic[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/tf[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rqt_py_common[${PYTHON_SINGLE_USEDEP}]
+"
+DEPEND="${RDEPEND}"