summaryrefslogtreecommitdiff
path: root/dev-ros/rosmsg/rosmsg-1.13.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-11-15 17:13:45 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-11-15 17:13:45 +0000
commite2d84e38284aeb9d522a7e935554340ddf0e4a6f (patch)
tree5a7444ee5f2af59431481999f729676090b1e0f3 /dev-ros/rosmsg/rosmsg-1.13.5.ebuild
parent519e4d5d99fc43d5c9a038098c029dc4ef9d6792 (diff)
gentoo resync : 15.11.2017
Diffstat (limited to 'dev-ros/rosmsg/rosmsg-1.13.5.ebuild')
-rw-r--r--dev-ros/rosmsg/rosmsg-1.13.5.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/rosmsg/rosmsg-1.13.5.ebuild b/dev-ros/rosmsg/rosmsg-1.13.5.ebuild
new file mode 100644
index 000000000000..5298eb858e66
--- /dev/null
+++ b/dev-ros/rosmsg/rosmsg-1.13.5.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit ros-catkin
+
+DESCRIPTION="Command-line tools for displaying information about message and services"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/genmsg[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rosbag[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"