summaryrefslogtreecommitdiff
path: root/dev-ros/rosconsole/rosconsole-1.12.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ros/rosconsole/rosconsole-1.12.5.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ros/rosconsole/rosconsole-1.12.5.ebuild')
-rw-r--r--dev-ros/rosconsole/rosconsole-1.12.5.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ros/rosconsole/rosconsole-1.12.5.ebuild b/dev-ros/rosconsole/rosconsole-1.12.5.ebuild
new file mode 100644
index 000000000000..b5e961658c14
--- /dev/null
+++ b/dev-ros/rosconsole/rosconsole-1.12.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS console output library"
+LICENSE="BSD"
+SLOT="0"
+IUSE="+log4cxx glog"
+
+RDEPEND="
+ dev-ros/cpp_common
+ dev-ros/rostime
+ dev-ros/rosunit
+ dev-libs/boost:=[threads]
+ log4cxx? ( dev-libs/log4cxx )
+ !log4cxx? ( glog? ( dev-cpp/glog ) )
+"
+DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/vector.patch" )
+
+src_configure() {
+ local ROSCONSOLE_BACKEND=""
+ if use log4cxx; then
+ ROSCONSOLE_BACKEND="log4cxx"
+ elif use glog; then
+ ROSCONSOLE_BACKEND="glog"
+ else
+ ROSCONSOLE_BACKEND="print"
+ fi
+ local mycatkincmakeargs=( "-DROSCONSOLE_BACKEND=${ROSCONSOLE_BACKEND}" )
+ ros-catkin_src_configure
+}