summaryrefslogtreecommitdiff
path: root/dev-ros/robot_pose_ekf/robot_pose_ekf-1.15.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-11 07:02:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-11 07:02:28 +0100
commit068424b26532f3551a81421a9be67ed206e5c11a (patch)
tree583b8d979899a463a4ef5b26d3d49e85df987623 /dev-ros/robot_pose_ekf/robot_pose_ekf-1.15.0.ebuild
parentd162ba1860a88062f4cd61f8b52fc303ba0b2991 (diff)
gentoo resync : 11.08.2021
Diffstat (limited to 'dev-ros/robot_pose_ekf/robot_pose_ekf-1.15.0.ebuild')
-rw-r--r--dev-ros/robot_pose_ekf/robot_pose_ekf-1.15.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ros/robot_pose_ekf/robot_pose_ekf-1.15.0.ebuild b/dev-ros/robot_pose_ekf/robot_pose_ekf-1.15.0.ebuild
new file mode 100644
index 000000000000..59f91b30ba19
--- /dev/null
+++ b/dev-ros/robot_pose_ekf/robot_pose_ekf-1.15.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-planning/robot_pose_ekf"
+KEYWORDS="~amd64 ~arm"
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Estimate the 3D pose of a robot from pose measurements from various sources"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/tf
+ sci-libs/orocos-bfl
+ dev-libs/boost:=[threads(+)]
+"
+DEPEND="${RDEPEND}
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ test? (
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ dev-cpp/gtest
+ )
+ virtual/pkgconfig"