summaryrefslogtreecommitdiff
path: root/dev-ros/robot_localization/robot_localization-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ros/robot_localization/robot_localization-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ros/robot_localization/robot_localization-9999.ebuild')
-rw-r--r--dev-ros/robot_localization/robot_localization-9999.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ros/robot_localization/robot_localization-9999.ebuild b/dev-ros/robot_localization/robot_localization-9999.ebuild
new file mode 100644
index 000000000000..d82b9bcddb0c
--- /dev/null
+++ b/dev-ros/robot_localization/robot_localization-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/cra-ros-pkg/robot_localization"
+KEYWORDS="~amd64"
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geographic_msgs dev-ros/geometry_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Package of nonlinear state estimation nodes"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/diagnostic_updater
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/eigen_conversions
+ dev-ros/geographic_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/message_filters
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/roscpp
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2
+ dev-ros/tf2_geometry_msgs
+ dev-ros/tf2_ros
+ dev-ros/xmlrpcpp
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}
+ dev-ros/roslint
+ dev-cpp/eigen:3
+ test? ( dev-ros/rosbag dev-ros/rostest dev-ros/rosunit )
+"