summaryrefslogtreecommitdiff
path: root/dev-ros/robot_localization
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ros/robot_localization
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ros/robot_localization')
-rw-r--r--dev-ros/robot_localization/Manifest4
-rw-r--r--dev-ros/robot_localization/metadata.xml11
-rw-r--r--dev-ros/robot_localization/robot_localization-2.4.0.ebuild39
-rw-r--r--dev-ros/robot_localization/robot_localization-9999.ebuild39
4 files changed, 93 insertions, 0 deletions
diff --git a/dev-ros/robot_localization/Manifest b/dev-ros/robot_localization/Manifest
new file mode 100644
index 000000000000..a9fa12cff2dc
--- /dev/null
+++ b/dev-ros/robot_localization/Manifest
@@ -0,0 +1,4 @@
+DIST robot_localization-2.4.0.tar.gz 6448252 SHA256 d951ede459b53890501ba1defe9c94863fff450b1242a40cb80f1a98a55dde44 SHA512 92a8c6d44f35a264fc16fe91d7ba6afcf361911164a96343d76d93c0263f0d6cb9e3b11f82cf30c0354a1ebb140cdb06348ae5ca92182dd85ab2e0fd77898724 WHIRLPOOL adeb6d9cbac433d533cfcc5eb5fc6c3dd09279da8a65296dfd74365de19e655b4ca6e2ad2bc4883ea0e1c2be82836e7bd116ca116fcf661d8f9304b35da20520
+EBUILD robot_localization-2.4.0.ebuild 1111 SHA256 c3f5426bf35d57f7d9ee527a98a95fc0e837a1ab4b86d10b5c6d04a9362b8dea SHA512 3d3764b82bfc865c76ca46c1d863e05d1cf697209328c067320a260af143f606cbb6a4d41792dd4a94cd23d54cf65b835133550fefade06cd34585084d25e022 WHIRLPOOL f78c261ac826f4e4f1d5af0fa75e32d9eb0651c6d7f3ce39a89654c5db38165b8e9b340e9442cd194c59b0851bbf8e3b7bf87fca63302297a10965af6e9afc14
+EBUILD robot_localization-9999.ebuild 1111 SHA256 c3f5426bf35d57f7d9ee527a98a95fc0e837a1ab4b86d10b5c6d04a9362b8dea SHA512 3d3764b82bfc865c76ca46c1d863e05d1cf697209328c067320a260af143f606cbb6a4d41792dd4a94cd23d54cf65b835133550fefade06cd34585084d25e022 WHIRLPOOL f78c261ac826f4e4f1d5af0fa75e32d9eb0651c6d7f3ce39a89654c5db38165b8e9b340e9442cd194c59b0851bbf8e3b7bf87fca63302297a10965af6e9afc14
+MISC metadata.xml 344 SHA256 224f65dff1ab2308d888026015a3d42f06b3660a6089a24e64ce73587cc79702 SHA512 682ee23502ff9b98b82cc8edb5dffafb1bde520ffa42ce8ab417e9c5dabab929286bb572e0988108201e29363315d12c8a5f55f841324fa339effe82ac1595c1 WHIRLPOOL 1730a40bba14c4a1a3a397d0a219d4b8e2f2b8720f840fa875322ed0eac716bad75a2591ed781ee54167ac4ce60c12e0fdea6b1b6a78276600639144264e959b
diff --git a/dev-ros/robot_localization/metadata.xml b/dev-ros/robot_localization/metadata.xml
new file mode 100644
index 000000000000..ef2c5aaa10e6
--- /dev/null
+++ b/dev-ros/robot_localization/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">cra-ros-pkg/robot_localization</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ros/robot_localization/robot_localization-2.4.0.ebuild b/dev-ros/robot_localization/robot_localization-2.4.0.ebuild
new file mode 100644
index 000000000000..d82b9bcddb0c
--- /dev/null
+++ b/dev-ros/robot_localization/robot_localization-2.4.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/cra-ros-pkg/robot_localization"
+KEYWORDS="~amd64"
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geographic_msgs dev-ros/geometry_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Package of nonlinear state estimation nodes"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/diagnostic_updater
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/eigen_conversions
+ dev-ros/geographic_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/message_filters
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/roscpp
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2
+ dev-ros/tf2_geometry_msgs
+ dev-ros/tf2_ros
+ dev-ros/xmlrpcpp
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}
+ dev-ros/roslint
+ dev-cpp/eigen:3
+ test? ( dev-ros/rosbag dev-ros/rostest dev-ros/rosunit )
+"
diff --git a/dev-ros/robot_localization/robot_localization-9999.ebuild b/dev-ros/robot_localization/robot_localization-9999.ebuild
new file mode 100644
index 000000000000..d82b9bcddb0c
--- /dev/null
+++ b/dev-ros/robot_localization/robot_localization-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/cra-ros-pkg/robot_localization"
+KEYWORDS="~amd64"
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geographic_msgs dev-ros/geometry_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Package of nonlinear state estimation nodes"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/diagnostic_updater
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/eigen_conversions
+ dev-ros/geographic_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/message_filters
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/roscpp
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2
+ dev-ros/tf2_geometry_msgs
+ dev-ros/tf2_ros
+ dev-ros/xmlrpcpp
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}
+ dev-ros/roslint
+ dev-cpp/eigen:3
+ test? ( dev-ros/rosbag dev-ros/rostest dev-ros/rosunit )
+"