summaryrefslogtreecommitdiff
path: root/dev-ros/nav_core/nav_core-1.15.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-25 19:22:13 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-03-25 19:22:13 +0100
commit6bd95d1f6320b8666a31ec949183aaa3088aa16f (patch)
treeff9f0cde8bfba5191f96c690c269c814c134a51e /dev-ros/nav_core/nav_core-1.15.2.ebuild
parentb279bbe94522565b8feb19b8e5f377d3ea76f157 (diff)
gentoo resync : 25.03.2018
Diffstat (limited to 'dev-ros/nav_core/nav_core-1.15.2.ebuild')
-rw-r--r--dev-ros/nav_core/nav_core-1.15.2.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ros/nav_core/nav_core-1.15.2.ebuild b/dev-ros/nav_core/nav_core-1.15.2.ebuild
new file mode 100644
index 000000000000..3461f7166e3d
--- /dev/null
+++ b/dev-ros/nav_core/nav_core-1.15.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Common interfaces for navigation specific robot actions"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf
+ dev-ros/costmap_2d
+"
+DEPEND="${RDEPEND}"