summaryrefslogtreecommitdiff
path: root/dev-ros/message_filters/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
commitb24bd25253fe093f722ab576d29fdc41d04cb1ee (patch)
tree0fcf2afd9f852c4d4c291cf8afaa2c244d598105 /dev-ros/message_filters/files
parent121ed4eec41fbf03e1998d09eede1bf449da63b9 (diff)
gentoo resync : 02.08.2019
Diffstat (limited to 'dev-ros/message_filters/files')
-rw-r--r--dev-ros/message_filters/files/boost.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ros/message_filters/files/boost.patch b/dev-ros/message_filters/files/boost.patch
new file mode 100644
index 000000000000..1acc778756a8
--- /dev/null
+++ b/dev-ros/message_filters/files/boost.patch
@@ -0,0 +1,26 @@
+commit 41f18edc9f2f0b1ef304ea25f148bd56a6bf3d70
+Author: Maarten de Vries <maarten@de-vri.es>
+Date: Thu Jan 31 00:58:29 2019 +0100
+
+ Remove signals from find_package(Boost COMPONENTS ...) (#1580)
+
+ The packages use signals2, not signals. Only boost libraries with
+ compiled code should be passed to find_package(Boost COMPONENTS ...),
+ and the signals2 library has always been header only.
+
+ Boost 1.69 has removed the deprecated signals library, so the otherwise
+ useless but harmless `signals` component now breaks the build.
+
+diff --git a/utilities/message_filters/CMakeLists.txt b/utilities/message_filters/CMakeLists.txt
+index 5694ac57e..d2b1477ad 100644
+--- a/utilities/message_filters/CMakeLists.txt
++++ b/utilities/message_filters/CMakeLists.txt
+@@ -13,7 +13,7 @@ catkin_package(
+ )
+ catkin_python_setup()
+
+-find_package(Boost REQUIRED COMPONENTS signals thread)
++find_package(Boost REQUIRED COMPONENTS thread)
+
+ include_directories(include ${catkin_INCLUDE_DIRS} ${Boost_INCLUDE_DIRS})
+ link_directories(${catkin_LIBRARY_DIRS})