summaryrefslogtreecommitdiff
path: root/dev-ros/laser_cb_detector/laser_cb_detector-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ros/laser_cb_detector/laser_cb_detector-9999.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ros/laser_cb_detector/laser_cb_detector-9999.ebuild')
-rw-r--r--dev-ros/laser_cb_detector/laser_cb_detector-9999.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ros/laser_cb_detector/laser_cb_detector-9999.ebuild b/dev-ros/laser_cb_detector/laser_cb_detector-9999.ebuild
new file mode 100644
index 000000000000..605a596b776e
--- /dev/null
+++ b/dev-ros/laser_cb_detector/laser_cb_detector-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/calibration"
+CATKIN_HAS_MESSAGES=yes
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/actionlib_msgs dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Extracts checkerboard corners from a dense laser snapshot"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=[threads]
+ dev-ros/actionlib[${PYTHON_USEDEP}]
+ dev-ros/cv_bridge
+ media-libs/opencv:=
+ dev-ros/image_cb_detector
+ dev-ros/message_filters
+ dev-ros/roscpp
+ dev-ros/settlerlib
+"
+DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/gcc6.patch" )