summaryrefslogtreecommitdiff
path: root/dev-ros/interval_intersection
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-07 00:16:33 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-07 00:16:33 +0100
commitd162ba1860a88062f4cd61f8b52fc303ba0b2991 (patch)
tree24cd2cf57f3932a24b96e4a0f6666489447e43ba /dev-ros/interval_intersection
parent590b9b7b03bf4651e099949e318755af7cfa81b8 (diff)
gentoo resync : 07.08.2021
Diffstat (limited to 'dev-ros/interval_intersection')
-rw-r--r--dev-ros/interval_intersection/Manifest2
-rw-r--r--dev-ros/interval_intersection/interval_intersection-0.10.15.ebuild28
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-ros/interval_intersection/Manifest b/dev-ros/interval_intersection/Manifest
index c1bad0344681..261e0e473b49 100644
--- a/dev-ros/interval_intersection/Manifest
+++ b/dev-ros/interval_intersection/Manifest
@@ -1,4 +1,6 @@
DIST calibration-0.10.14.tar.gz 112475 BLAKE2B a43bf316b3eea30f5f3e273e0dd2754fe819a1aa246237cb1ecc4bc49463abbd3eb71f77579fc0655c483ad9ac259bb027ac014fc5ec368a73bada61dedf6712 SHA512 5ef17cd21e04c134717859ecb12c4e7fc0086b044cf7d35d40bd43439a0f24e8ad41fe7b5fa37dcc8ec5e4abb2be8f64d86510706a3d97510cf1b92c2196ad40
+DIST calibration-0.10.15.tar.gz 115940 BLAKE2B 43c8564ad8f15894d04571fbb3c6bc2059a5d232de3fb6225b715b078a11fef2e19283e3f0587ed47f2d52784ade22bebdf4680f6b30c585da2fbbfa1c45b0a5 SHA512 06ffc9ae6872b914eb6954996d165e2aa65d786756896a21be1ab3b5c20f1df3340e2fdf9804bc3cd78089f5b2e05eaed2a4376e70e98ccaaa8a88d95c3f4894
EBUILD interval_intersection-0.10.14-r1.ebuild 706 BLAKE2B 1bd3d95736cea60b8971ba06d5c05b30de0e39afd58d56d5ae8beac93f8dfa7d30801fee5adad585c96e5f6365dc81172f11a93743ccbd428b139a786af96f5c SHA512 09615189a77667409d10e69b19859e9367dfc75322294a71c56cfe56dfeed651e460b78e31238d5755a7b745fe147c973ec63f08107a9ef8af2768e6c4e7f4c4
+EBUILD interval_intersection-0.10.15.ebuild 706 BLAKE2B 1bd3d95736cea60b8971ba06d5c05b30de0e39afd58d56d5ae8beac93f8dfa7d30801fee5adad585c96e5f6365dc81172f11a93743ccbd428b139a786af96f5c SHA512 09615189a77667409d10e69b19859e9367dfc75322294a71c56cfe56dfeed651e460b78e31238d5755a7b745fe147c973ec63f08107a9ef8af2768e6c4e7f4c4
EBUILD interval_intersection-9999.ebuild 706 BLAKE2B 1bd3d95736cea60b8971ba06d5c05b30de0e39afd58d56d5ae8beac93f8dfa7d30801fee5adad585c96e5f6365dc81172f11a93743ccbd428b139a786af96f5c SHA512 09615189a77667409d10e69b19859e9367dfc75322294a71c56cfe56dfeed651e460b78e31238d5755a7b745fe147c973ec63f08107a9ef8af2768e6c4e7f4c4
MISC metadata.xml 340 BLAKE2B 52b47839e0051b2f1813313ae3989819be9668c093763a9c9518302d5b5832142fd02e6c7427493411d2b3ad3143d41180aa1c0f890362b43258109fc5b858b3 SHA512 de7b08cf3292d6c46f7a6e954ece0a32c8e2f4d67bc5212ce755662b8abf50425d54c00e0601ba943a4a9835f32c3df63ef87d5655788510ed86f05dd485a963
diff --git a/dev-ros/interval_intersection/interval_intersection-0.10.15.ebuild b/dev-ros/interval_intersection/interval_intersection-0.10.15.ebuild
new file mode 100644
index 000000000000..3d821a2d187a
--- /dev/null
+++ b/dev-ros/interval_intersection/interval_intersection-0.10.15.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-perception/calibration"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/actionlib_msgs dev-ros/geometry_msgs dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Tools for calculating the intersection of interval messages"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=[threads(+)]
+ dev-ros/actionlib
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-ros/roscpp_serialization
+ dev-ros/rostime
+"
+DEPEND="${RDEPEND}
+ dev-ros/calibration_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ test? ( dev-cpp/gtest )"