summaryrefslogtreecommitdiff
path: root/dev-ros/interval_intersection/interval_intersection-0.10.15.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/interval_intersection/interval_intersection-0.10.15.ebuild')
-rw-r--r--dev-ros/interval_intersection/interval_intersection-0.10.15.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ros/interval_intersection/interval_intersection-0.10.15.ebuild b/dev-ros/interval_intersection/interval_intersection-0.10.15.ebuild
new file mode 100644
index 000000000000..3d821a2d187a
--- /dev/null
+++ b/dev-ros/interval_intersection/interval_intersection-0.10.15.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-perception/calibration"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/actionlib_msgs dev-ros/geometry_msgs dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Tools for calculating the intersection of interval messages"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=[threads(+)]
+ dev-ros/actionlib
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-ros/roscpp_serialization
+ dev-ros/rostime
+"
+DEPEND="${RDEPEND}
+ dev-ros/calibration_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ test? ( dev-cpp/gtest )"