summaryrefslogtreecommitdiff
path: root/dev-ros/imu_complementary_filter/imu_complementary_filter-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ros/imu_complementary_filter/imu_complementary_filter-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ros/imu_complementary_filter/imu_complementary_filter-9999.ebuild')
-rw-r--r--dev-ros/imu_complementary_filter/imu_complementary_filter-9999.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ros/imu_complementary_filter/imu_complementary_filter-9999.ebuild b/dev-ros/imu_complementary_filter/imu_complementary_filter-9999.ebuild
new file mode 100644
index 000000000000..d9eb91e64e14
--- /dev/null
+++ b/dev-ros/imu_complementary_filter/imu_complementary_filter-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ccny-ros-pkg/imu_tools"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Fuses angular velocities, accelerations, and (optionally) magnetic readings from an IMU device"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/message_filters
+ dev-ros/roscpp
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}
+ dev-ros/cmake_modules
+"