summaryrefslogtreecommitdiff
path: root/dev-ros/image_rotate/image_rotate-1.12.22-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-30 01:11:30 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-30 01:11:30 +0000
commit76dfef0cec9170000357d2f354e412daf48941fc (patch)
tree56647120c0ee20ab3494475c86722034cd194b02 /dev-ros/image_rotate/image_rotate-1.12.22-r1.ebuild
parentccf84bcd604130256d1377cd58f0a634ae6ee20f (diff)
gentoo resync : 30.12.2017
Diffstat (limited to 'dev-ros/image_rotate/image_rotate-1.12.22-r1.ebuild')
-rw-r--r--dev-ros/image_rotate/image_rotate-1.12.22-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ros/image_rotate/image_rotate-1.12.22-r1.ebuild b/dev-ros/image_rotate/image_rotate-1.12.22-r1.ebuild
new file mode 100644
index 000000000000..eecbe94dd9f4
--- /dev/null
+++ b/dev-ros/image_rotate/image_rotate-1.12.22-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_pipeline"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Rotates an image stream minimizing the angle between an arbitrary vector and the camera frame"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cv_bridge
+ media-libs/opencv:=
+ dev-ros/dynamic_reconfigure
+ dev-ros/eigen_conversions
+ dev-ros/image_transport
+ dev-ros/nodelet
+ dev-libs/console_bridge:=
+ dev-ros/roscpp
+ dev-ros/tf2
+ dev-ros/tf2_geometry_msgs
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}"