summaryrefslogtreecommitdiff
path: root/dev-ros/image_proc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-ros/image_proc
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-ros/image_proc')
-rw-r--r--dev-ros/image_proc/Manifest5
-rw-r--r--dev-ros/image_proc/files/ocv_leak.patch13
-rw-r--r--dev-ros/image_proc/image_proc-1.15.2-r1.ebuild (renamed from dev-ros/image_proc/image_proc-1.15.2.ebuild)1
-rw-r--r--dev-ros/image_proc/image_proc-9999.ebuild1
4 files changed, 18 insertions, 2 deletions
diff --git a/dev-ros/image_proc/Manifest b/dev-ros/image_proc/Manifest
index b4900cfd16c7..4000e1d75d07 100644
--- a/dev-ros/image_proc/Manifest
+++ b/dev-ros/image_proc/Manifest
@@ -1,4 +1,5 @@
+AUX ocv_leak.patch 587 BLAKE2B 1233e318496eab850c8da43383a4dabf9997db88bf103c4652efb7a1b481d22832b90cae48294c2f0b52ba082b63ca4369445f1c4ff2092847fad0c6e14ab98b SHA512 37e1f7af29f73f972991a5e204e9d69169a4131ccdd7b19f7fa34232d0706c88303bf5f7bd476be0a21654dfb558a5e6af86d27aca8da35122b46c4846d6dee0
DIST image_pipeline-1.15.2.tar.gz 147570 BLAKE2B 7e6ecad344e38426148017c4bdd109cdb505201256b811d7479b2fa5f2b6a94f94708ffd0e2a3c273f09fb8db0afdedb6955320bc142e4b48fbf94eeef45b453 SHA512 8fe9fa7759d83b2585589c6667c82b154c6ab748aa1644e8a58c75550e4c581fdea1b42f91a8c64df4eb7a06b33a76e55325268f314f3ec1f06ee38ee7b06bfc
-EBUILD image_proc-1.15.2.ebuild 758 BLAKE2B a543f793a421450b7cd7012091011484195b9ac822c56344643e8866de9cccdd045904a87ead629c0d247b81dccbb1a06c961113f7067c7a4ed503490a471144 SHA512 1a77611d5d36d095927094a6fb97c7663ec0cbf1fca551f60e0df2a434d15afb3b0ddea95ff10d3c71cc41af6aab22d12616011cf6f394d2ca63511744cbaf04
-EBUILD image_proc-9999.ebuild 758 BLAKE2B a543f793a421450b7cd7012091011484195b9ac822c56344643e8866de9cccdd045904a87ead629c0d247b81dccbb1a06c961113f7067c7a4ed503490a471144 SHA512 1a77611d5d36d095927094a6fb97c7663ec0cbf1fca551f60e0df2a434d15afb3b0ddea95ff10d3c71cc41af6aab22d12616011cf6f394d2ca63511744cbaf04
+EBUILD image_proc-1.15.2-r1.ebuild 799 BLAKE2B 91a407f07453a298f051b9d3deb16a0fab4c1e9386179191ce13976ff14df5e0433bedc83777d1dc4dffb6f68a3d3dda62519337006599139db966f31796c36e SHA512 70447b0bd33cdcb1eae9422d456ae66ad8ae78e4ef089e8bc0fddb8b52872ede3be3b7a05c5155393a789cf097ec5c39ba62a7a293face19153091ecbc09fc01
+EBUILD image_proc-9999.ebuild 799 BLAKE2B 91a407f07453a298f051b9d3deb16a0fab4c1e9386179191ce13976ff14df5e0433bedc83777d1dc4dffb6f68a3d3dda62519337006599139db966f31796c36e SHA512 70447b0bd33cdcb1eae9422d456ae66ad8ae78e4ef089e8bc0fddb8b52872ede3be3b7a05c5155393a789cf097ec5c39ba62a7a293face19153091ecbc09fc01
MISC metadata.xml 343 BLAKE2B 338674597d8027dfe18c53c2322f9f1ad7cb177c988a820dfbacbb45cf25ed32fbb65fc0fe08de174b20933d2cbfb7118e1d01b5e9d852f226cbd581da046bb4 SHA512 c16dd878a20c747d32f8445c8eb454b51ffaf8543c1f722cca0e6508d849107e89a2cda92b0d206ef618ae1075d51e542c4178e903f3cb35efd285a5fff0cfcb
diff --git a/dev-ros/image_proc/files/ocv_leak.patch b/dev-ros/image_proc/files/ocv_leak.patch
new file mode 100644
index 000000000000..79722625d327
--- /dev/null
+++ b/dev-ros/image_proc/files/ocv_leak.patch
@@ -0,0 +1,13 @@
+Index: image_proc/CMakeLists.txt
+===================================================================
+--- image_proc.orig/CMakeLists.txt
++++ image_proc/CMakeLists.txt
+@@ -4,7 +4,7 @@ project(image_proc)
+ find_package(catkin REQUIRED)
+
+ find_package(catkin REQUIRED cv_bridge dynamic_reconfigure image_geometry image_transport nodelet nodelet_topic_tools roscpp sensor_msgs)
+-find_package(OpenCV REQUIRED)
++find_package(OpenCV REQUIRED COMPONENTS opencv_core opencv_imgproc opencv_highgui)
+ find_package(Boost REQUIRED COMPONENTS thread)
+
+ if(cv_bridge_VERSION VERSION_GREATER "1.12.0")
diff --git a/dev-ros/image_proc/image_proc-1.15.2.ebuild b/dev-ros/image_proc/image_proc-1.15.2-r1.ebuild
index e38214ace5bb..ee3903c63127 100644
--- a/dev-ros/image_proc/image_proc-1.15.2.ebuild
+++ b/dev-ros/image_proc/image_proc-1.15.2-r1.ebuild
@@ -33,3 +33,4 @@ DEPEND="${RDEPEND}
dev-ros/camera_calibration_parsers
)
"
+PATCHES=( "${FILESDIR}/ocv_leak.patch" )
diff --git a/dev-ros/image_proc/image_proc-9999.ebuild b/dev-ros/image_proc/image_proc-9999.ebuild
index e38214ace5bb..ee3903c63127 100644
--- a/dev-ros/image_proc/image_proc-9999.ebuild
+++ b/dev-ros/image_proc/image_proc-9999.ebuild
@@ -33,3 +33,4 @@ DEPEND="${RDEPEND}
dev-ros/camera_calibration_parsers
)
"
+PATCHES=( "${FILESDIR}/ocv_leak.patch" )