summaryrefslogtreecommitdiff
path: root/dev-ros/image_proc/files/ocv_leak.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/image_proc/files/ocv_leak.patch')
-rw-r--r--dev-ros/image_proc/files/ocv_leak.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/dev-ros/image_proc/files/ocv_leak.patch b/dev-ros/image_proc/files/ocv_leak.patch
new file mode 100644
index 000000000000..79722625d327
--- /dev/null
+++ b/dev-ros/image_proc/files/ocv_leak.patch
@@ -0,0 +1,13 @@
+Index: image_proc/CMakeLists.txt
+===================================================================
+--- image_proc.orig/CMakeLists.txt
++++ image_proc/CMakeLists.txt
+@@ -4,7 +4,7 @@ project(image_proc)
+ find_package(catkin REQUIRED)
+
+ find_package(catkin REQUIRED cv_bridge dynamic_reconfigure image_geometry image_transport nodelet nodelet_topic_tools roscpp sensor_msgs)
+-find_package(OpenCV REQUIRED)
++find_package(OpenCV REQUIRED COMPONENTS opencv_core opencv_imgproc opencv_highgui)
+ find_package(Boost REQUIRED COMPONENTS thread)
+
+ if(cv_bridge_VERSION VERSION_GREATER "1.12.0")