summaryrefslogtreecommitdiff
path: root/dev-ros/hardware_interface/hardware_interface-0.19.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
commit24fd814c326e282c4321965c31f341dad77e270d (patch)
tree033d63b33c21a3209964ab56005bb9bdd523630d /dev-ros/hardware_interface/hardware_interface-0.19.4.ebuild
parent129160ec854dca4c3fedb5bcfbcb56930371da0f (diff)
gentoo resync : 08.01.2021
Diffstat (limited to 'dev-ros/hardware_interface/hardware_interface-0.19.4.ebuild')
-rw-r--r--dev-ros/hardware_interface/hardware_interface-0.19.4.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/dev-ros/hardware_interface/hardware_interface-0.19.4.ebuild b/dev-ros/hardware_interface/hardware_interface-0.19.4.ebuild
new file mode 100644
index 000000000000..3cbf6c2cb246
--- /dev/null
+++ b/dev-ros/hardware_interface/hardware_interface-0.19.4.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-controls/ros_control"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Hardware Interface base class"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-ros/roscpp"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest dev-ros/rostest )"