summaryrefslogtreecommitdiff
path: root/dev-ros/gmapping
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
commitf1af93971b7490792d8541bc790e0d8c6d787059 (patch)
treea38046712bbc3a3844d77452d16c84e716caa3d4 /dev-ros/gmapping
parentfc637fb28da700da71ec2064d65ca5a7a31b9c6c (diff)
gentoo resync : 06.08.2019
Diffstat (limited to 'dev-ros/gmapping')
-rw-r--r--dev-ros/gmapping/Manifest5
-rw-r--r--dev-ros/gmapping/files/boost170.patch13
-rw-r--r--dev-ros/gmapping/gmapping-1.4.0.ebuild27
-rw-r--r--dev-ros/gmapping/gmapping-9999.ebuild4
4 files changed, 46 insertions, 3 deletions
diff --git a/dev-ros/gmapping/Manifest b/dev-ros/gmapping/Manifest
index 8f539baa8058..da87d350f1d1 100644
--- a/dev-ros/gmapping/Manifest
+++ b/dev-ros/gmapping/Manifest
@@ -1,4 +1,7 @@
+AUX boost170.patch 428 BLAKE2B 047a099ab5a36f3f603ecc10b5cf1e0edb25c880bf1ade298dfcfef7864bb9c445f2f0902299857003d8e32dcf7612ad149a70364fb6fa64fa86b84b620b346b SHA512 e9a2bb68993387b4ac6268d15151a4feedf1c6f73c84ee927590220edc1b826e18355fa3553d3605ca1afabd5b7b74b7e8c242797965b17fa9aa7449b406c493
DIST slam_gmapping-1.3.10.tar.gz 21032 BLAKE2B cca0779e64d45622dad4ec29cb3c1d0162176038288c0aa7b117f1a76a7655f3af3024dba7ff1025948e400e0176794a553e357a235187d9196161a635ab6d01 SHA512 fa4485ddc9fcfaac63a63d209a5a994e33e78546a39edcf47eb3c3f1775f0d87a1f562319058868838990bbf85a9515ff0228779dce7531148f208b3522e7e7a
+DIST slam_gmapping-1.4.0.tar.gz 21123 BLAKE2B 088d1bfaa69bf98eb2b2176afbfadf843f5f478f9c54dc7eb32fa91116da31bab66f9a1ac09d0535629cc5a7f604d153c90c5a25f173fb867369aa9e33d4d7b2 SHA512 ae7984716113e24e1bced88523729481829303a2b88d247b8fc8bdd23c0f38b4ce6260d7086d79a6653ecfdbe8ba60ae011af20180ffcb5025cd9d347d3e76b1
EBUILD gmapping-1.3.10.ebuild 546 BLAKE2B 9a6c5e78a43ba77c86dd2a1640ef56bcd2f481a830c3333ab4b87f84f4c761c8728e811e5e314b5eed9809e987fd2b8a0a72aaf58b62f6c4dea561d2101682ad SHA512 41823e5fad9201ca764d2a22af8de2c88b19e449f8d2fec8682a5d21381e35f29a17b729d3b5cc5faacd50057fe5e69b110f7756b414b859528656bea3a963b8
-EBUILD gmapping-9999.ebuild 546 BLAKE2B 9a6c5e78a43ba77c86dd2a1640ef56bcd2f481a830c3333ab4b87f84f4c761c8728e811e5e314b5eed9809e987fd2b8a0a72aaf58b62f6c4dea561d2101682ad SHA512 41823e5fad9201ca764d2a22af8de2c88b19e449f8d2fec8682a5d21381e35f29a17b729d3b5cc5faacd50057fe5e69b110f7756b414b859528656bea3a963b8
+EBUILD gmapping-1.4.0.ebuild 572 BLAKE2B d57a0f72d1343457fef74a3da8cd76103526209a99a2ab4ebcf815672ed387aa4d6504068f3da6d3441e6e51147565a0c200ab9ba109e54d6b77a3bd0d86f260 SHA512 b64efeb32bc2b14c13a3e898358a8ed7094e1d7bbc201333ac850794583a4c309ddaa61229fc2d99f67a4b8e55879ab0ec256e82b4223f9fcf8fc2dd389abe8a
+EBUILD gmapping-9999.ebuild 531 BLAKE2B 3674f6396da0e8f9dc6b0bbb16e5d627678b02a03807775f54fc7f26910cfe918b00445b780918b74ade87a304543b632c08580cc205aba1e5ab5bceb0b3f260 SHA512 019a01e8efeb054beaa804025619988c5b42ea220621c27b57deb0da4069aa3a964f10f897aa255bf09ffb7be07a3177d305bd7e747c0ec769769ddabc7d475c
MISC metadata.xml 342 BLAKE2B 72a1fe4f1e7971418dbb3f5b1e78de71a77819b9fa7200feb2ce0abec5b50a5435c5e5541d290bfd23c7acee5a6920280934067c84e4716bd9f6bb0cc634544d SHA512 2a5beef664e8c79b9e4d858d0dc093068c6e462456ae6066ea637f4b725e5c7184dd65769906c34e55eb6b03949e957edba34b84a587e1daec784e1f74ea287c
diff --git a/dev-ros/gmapping/files/boost170.patch b/dev-ros/gmapping/files/boost170.patch
new file mode 100644
index 000000000000..e3a599471991
--- /dev/null
+++ b/dev-ros/gmapping/files/boost170.patch
@@ -0,0 +1,13 @@
+Index: gmapping/CMakeLists.txt
+===================================================================
+--- gmapping.orig/CMakeLists.txt
++++ gmapping/CMakeLists.txt
+@@ -3,7 +3,7 @@ project(gmapping)
+
+ find_package(catkin REQUIRED nav_msgs nodelet openslam_gmapping roscpp tf rosbag_storage)
+
+-find_package(Boost REQUIRED signals)
++find_package(Boost REQUIRED)
+
+ include_directories(${Boost_INCLUDE_DIRS} ${catkin_INCLUDE_DIRS})
+
diff --git a/dev-ros/gmapping/gmapping-1.4.0.ebuild b/dev-ros/gmapping/gmapping-1.4.0.ebuild
new file mode 100644
index 000000000000..aaad570edc05
--- /dev/null
+++ b/dev-ros/gmapping/gmapping-1.4.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/slam_gmapping"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS wrapper for OpenSlam's Gmapping"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/openslam_gmapping
+ dev-ros/rosbag_storage
+ dev-ros/gmapping
+"
+DEPEND="${RDEPEND}
+ dev-ros/rostest"
+PATCHES=( "${FILESDIR}/boost170.patch" )
diff --git a/dev-ros/gmapping/gmapping-9999.ebuild b/dev-ros/gmapping/gmapping-9999.ebuild
index ca6f43afe50c..307f03f929b1 100644
--- a/dev-ros/gmapping/gmapping-9999.ebuild
+++ b/dev-ros/gmapping/gmapping-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -9,7 +9,7 @@ ROS_SUBDIR=${PN}
inherit ros-catkin
DESCRIPTION="ROS wrapper for OpenSlam's Gmapping"
-LICENSE="CC-BY-NC-SA-2.5"
+LICENSE="BSD"
SLOT="0"
IUSE=""