summaryrefslogtreecommitdiff
path: root/dev-ros/global_planner/global_planner-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ros/global_planner/global_planner-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ros/global_planner/global_planner-9999.ebuild')
-rw-r--r--dev-ros/global_planner/global_planner-9999.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ros/global_planner/global_planner-9999.ebuild b/dev-ros/global_planner/global_planner-9999.ebuild
new file mode 100644
index 000000000000..7145234ce39d
--- /dev/null
+++ b/dev-ros/global_planner/global_planner-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Path planner library and node"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/costmap_2d
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/nav_core
+ dev-ros/navfn
+ dev-ros/pluginlib
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}"