summaryrefslogtreecommitdiff
path: root/dev-ros/cv_bridge/cv_bridge-1.12.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-11-15 17:13:45 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-11-15 17:13:45 +0000
commite2d84e38284aeb9d522a7e935554340ddf0e4a6f (patch)
tree5a7444ee5f2af59431481999f729676090b1e0f3 /dev-ros/cv_bridge/cv_bridge-1.12.7.ebuild
parent519e4d5d99fc43d5c9a038098c029dc4ef9d6792 (diff)
gentoo resync : 15.11.2017
Diffstat (limited to 'dev-ros/cv_bridge/cv_bridge-1.12.7.ebuild')
-rw-r--r--dev-ros/cv_bridge/cv_bridge-1.12.7.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/cv_bridge/cv_bridge-1.12.7.ebuild b/dev-ros/cv_bridge/cv_bridge-1.12.7.ebuild
new file mode 100644
index 000000000000..091646aa633e
--- /dev/null
+++ b/dev-ros/cv_bridge/cv_bridge-1.12.7.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/vision_opencv"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Converts between ROS Image messages and OpenCV images"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rosconsole
+ >=media-libs/opencv-3:=[contrib(+)]
+ dev-libs/boost:=[threads,python,${PYTHON_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"