summaryrefslogtreecommitdiff
path: root/dev-ros/costmap_2d
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-25 19:22:13 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-03-25 19:22:13 +0100
commit6bd95d1f6320b8666a31ec949183aaa3088aa16f (patch)
treeff9f0cde8bfba5191f96c690c269c814c134a51e /dev-ros/costmap_2d
parentb279bbe94522565b8feb19b8e5f377d3ea76f157 (diff)
gentoo resync : 25.03.2018
Diffstat (limited to 'dev-ros/costmap_2d')
-rw-r--r--dev-ros/costmap_2d/Manifest2
-rw-r--r--dev-ros/costmap_2d/costmap_2d-1.15.2.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-ros/costmap_2d/Manifest b/dev-ros/costmap_2d/Manifest
index fda1d5afe29d..66a135740574 100644
--- a/dev-ros/costmap_2d/Manifest
+++ b/dev-ros/costmap_2d/Manifest
@@ -1,4 +1,6 @@
DIST navigation-1.15.1.tar.gz 346480 BLAKE2B 29f9a0b6f2c62bd21a7cb87a64b490c845bb7db4af338fd094744abb22402df7eedc8c164b64f93f2d67dabaff99ca3b946b45e93173bed74834d9e3668726ad SHA512 25c5093bf7acca9d15d46bb2d0ae7e4ce0fa45f18b32d1626668dcbd33732317e8535b978e7225d86391472c517f05acb7736f31a7c511c8736ab8a22c7af4b0
+DIST navigation-1.15.2.tar.gz 348985 BLAKE2B 866779425828b1e4c3a044654ae41f33643646ca70cf6841f23bce265add2c420bf0934a41a6b29fa65fc421228a31dc15e9fb0f6cc4295ce12adbbb627b43d4 SHA512 582422756b31b4d83e929e3c723e7205e772b9775fcf618c9bd5d3c54af1f20e9bc8a0143626750c0c3cffeb0cbea8f8706b7e66f62dc037cfe12b05f23ee142
EBUILD costmap_2d-1.15.1-r1.ebuild 1007 BLAKE2B 9b8b2fa26faf207a3d16dbf2562ea3b07377576a37da86d8c996a4a29d344ab111107f72411b7d5dce788e0410b5893f9154589fcfcd226600843a9a0cc99712 SHA512 e3098b94f091436dcb0e730da4046493152307822b25504a833a3fc4088f77f37cd46fec9e2d232f0b88579699ad0e0939bbf1f1c3ec7be358ebb0a59e403530
+EBUILD costmap_2d-1.15.2.ebuild 1007 BLAKE2B aae47e6fb1d3b1bd4bce8e2c8ca1a07a9676ba7119bd137a6e59417a5ce15a3b77351e98dbfee724278762330bf4906e2a279eb294d5a69cb97ded57a056291d SHA512 011232bd8d618e6efbefc4db9e55f19ae22da2d1a79a5a906df30e36d0b75a030b280bd1d5227fc90a6df6a8b31b6ef7c90856c335fddcbbb97517e8c1715358
EBUILD costmap_2d-9999.ebuild 1007 BLAKE2B 9b8b2fa26faf207a3d16dbf2562ea3b07377576a37da86d8c996a4a29d344ab111107f72411b7d5dce788e0410b5893f9154589fcfcd226600843a9a0cc99712 SHA512 e3098b94f091436dcb0e730da4046493152307822b25504a833a3fc4088f77f37cd46fec9e2d232f0b88579699ad0e0939bbf1f1c3ec7be358ebb0a59e403530
MISC metadata.xml 337 BLAKE2B ecfbf3d0b63a1b876065d04b3d52daa0442e3bcaf060836731012a1e698b3aea06ff292d892035feb2fb0fc257d6d8462d013ccc67f2650177c9cdba4d051d44 SHA512 f5df7464100fa15a3d2ad11cc620007500a5cb5ea7be67ac45819a541dd4ae53ce476231d475acf4dfe7e7bf0c31281325dc4e003867d1cc01a29353bb5ea09e
diff --git a/dev-ros/costmap_2d/costmap_2d-1.15.2.ebuild b/dev-ros/costmap_2d/costmap_2d-1.15.2.ebuild
new file mode 100644
index 000000000000..afb1c245ae4e
--- /dev/null
+++ b/dev-ros/costmap_2d/costmap_2d-1.15.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python2_7 )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geometry_msgs dev-ros/map_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Creates a 2D costmap from sensor data"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+REQUIRED_USE="ros_messages_cxx"
+
+RDEPEND="
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/laser_geometry
+ dev-ros/message_filters
+ dev-ros/nav_msgs
+ dev-ros/pcl_conversions
+ dev-ros/pcl_ros
+ dev-ros/pluginlib
+ dev-ros/roscpp
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/visualization_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf
+ dev-ros/voxel_grid
+ dev-cpp/eigen:3
+ sci-libs/pcl:=
+ dev-libs/boost:=[threads]
+ dev-libs/tinyxml2:=
+"
+DEPEND="${RDEPEND}
+ dev-ros/cmake_modules
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"