summaryrefslogtreecommitdiff
path: root/dev-ros/combined_robot_hw
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-21 18:59:32 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-21 18:59:32 +0100
commit520a5b56dff7c24c9d42eafec142cb78b44f8e3e (patch)
treef562f705600dbd2292e97c0b4145787c2a8d1f97 /dev-ros/combined_robot_hw
parent3811bc3072bf19e2be351d2c63f81532945c0f21 (diff)
gentoo resync : 21.07.2018
Diffstat (limited to 'dev-ros/combined_robot_hw')
-rw-r--r--dev-ros/combined_robot_hw/Manifest4
-rw-r--r--dev-ros/combined_robot_hw/combined_robot_hw-0.15.0.ebuild24
-rw-r--r--dev-ros/combined_robot_hw/combined_robot_hw-9999.ebuild4
3 files changed, 29 insertions, 3 deletions
diff --git a/dev-ros/combined_robot_hw/Manifest b/dev-ros/combined_robot_hw/Manifest
index eaba1812df48..0dd4943e7a04 100644
--- a/dev-ros/combined_robot_hw/Manifest
+++ b/dev-ros/combined_robot_hw/Manifest
@@ -1,4 +1,6 @@
DIST ros_control-0.14.2.tar.gz 655686 BLAKE2B e3cf0ce87c8d5324f202c1e15ece973b004d7719e30577a5661c478278826da715cd2d54f62d6def0e447d7d7ec26c3d4f4c7b2fd3c548bff960a6bdf0258fa4 SHA512 8368ae786ca0621fc560f6bc32e754757da0f3e4594039425047d3370c5c55a4a2836dc220452d47df49df1e609d79de976c0fe45d83bd62cff64fd5549f993b
+DIST ros_control-0.15.0.tar.gz 657854 BLAKE2B 102c17265df13d4454249f9752491664d9c8d4354c417e99aaf7845fbea2992fbfde674e22e8415e4b55274aba6964473cc6663c0784f78cf7bb87fc232d5c30 SHA512 be1b208631a3018f06384bf342f6d909b082d48e5509bb2bdac1ce04eddad56ac83f8cf5c10a0c66650c2c7defa04680950bf5417723e2f8551055051c4fcc99
EBUILD combined_robot_hw-0.14.2.ebuild 469 BLAKE2B e80681e6738a357fa581c2fd6e05f1063720760dd72a30353390a283c35b52cc458f77642375ebd5904d6c2e807b9db26d90ecd0e238923fea9153ca66f52d5d SHA512 7310b5b0cd485a9afd95ea427e3bade40e4aedfbbaf2ba1fce36bb36a832b3375a8efb5e49f5b5705a2d6b13e3009c63f3bf240b45a8021ef79552134db3efa0
-EBUILD combined_robot_hw-9999.ebuild 469 BLAKE2B a5cb02705b91b54abf059372ce7ddf416734ed69a45e96871be1e69128e80bb38d8dfa9f3b195b9a21d09181bea6b4b57d64262a57f43d86dd269febc7a22ac7 SHA512 958b39cd5a44c30a86b3387da912e96cdedbcfdc0c7fdb0205a99be1cd98ddccfda7d01f40fda3162dcbc4b92b9f91b3c1884493d34e57d277427f27ec46ba84
+EBUILD combined_robot_hw-0.15.0.ebuild 469 BLAKE2B 044469c633f200170ddd3d070f98288bdb743e6ecb4c629a50d04a5bdd51508b9eddc1b192e9eb941400e62b6f307f838552c1d3598d292b12cff0eb9b34e0b9 SHA512 f3c945807062eac38f6e83fdcb1431d05f78d1cd88c1907754e205f56ca00a5f046377f747e19d4feb888e30df17675ed2cc3842dbc53ac46cdc61ff61bf8307
+EBUILD combined_robot_hw-9999.ebuild 469 BLAKE2B 044469c633f200170ddd3d070f98288bdb743e6ecb4c629a50d04a5bdd51508b9eddc1b192e9eb941400e62b6f307f838552c1d3598d292b12cff0eb9b34e0b9 SHA512 f3c945807062eac38f6e83fdcb1431d05f78d1cd88c1907754e205f56ca00a5f046377f747e19d4feb888e30df17675ed2cc3842dbc53ac46cdc61ff61bf8307
MISC metadata.xml 338 BLAKE2B 3206fecd7746b95f57f5e5a56f0098ba6879e09516fa13e01211fdab39b4917ebf9d3c95fc97f2e73b2bec2036b6f747581ed85f19b7cc4156fd94f186689a1a SHA512 7421fdc9a470e8ad0fa85cfece8dd02db2790e8718508de2e9e57c8788452c0323c5ac339b49c01c3478ebb35e134de9a2adaebc7744f1e61e66635fdb7edb10
diff --git a/dev-ros/combined_robot_hw/combined_robot_hw-0.15.0.ebuild b/dev-ros/combined_robot_hw/combined_robot_hw-0.15.0.ebuild
new file mode 100644
index 000000000000..99715e8c95e0
--- /dev/null
+++ b/dev-ros/combined_robot_hw/combined_robot_hw-0.15.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-controls/ros_control"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Combined Robot HW class"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-ros/hardware_interface-0.15
+ dev-ros/pluginlib
+ dev-libs/tinyxml2:=
+ dev-ros/roscpp
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/combined_robot_hw/combined_robot_hw-9999.ebuild b/dev-ros/combined_robot_hw/combined_robot_hw-9999.ebuild
index d554239e743b..99715e8c95e0 100644
--- a/dev-ros/combined_robot_hw/combined_robot_hw-9999.ebuild
+++ b/dev-ros/combined_robot_hw/combined_robot_hw-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -14,7 +14,7 @@ SLOT="0"
IUSE=""
RDEPEND="
- >=dev-ros/hardware_interface-0.11
+ >=dev-ros/hardware_interface-0.15
dev-ros/pluginlib
dev-libs/tinyxml2:=
dev-ros/roscpp