summaryrefslogtreecommitdiff
path: root/dev-ros/carrot_planner
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-25 19:22:13 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-03-25 19:22:13 +0100
commit6bd95d1f6320b8666a31ec949183aaa3088aa16f (patch)
treeff9f0cde8bfba5191f96c690c269c814c134a51e /dev-ros/carrot_planner
parentb279bbe94522565b8feb19b8e5f377d3ea76f157 (diff)
gentoo resync : 25.03.2018
Diffstat (limited to 'dev-ros/carrot_planner')
-rw-r--r--dev-ros/carrot_planner/Manifest2
-rw-r--r--dev-ros/carrot_planner/carrot_planner-1.15.2.ebuild26
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-ros/carrot_planner/Manifest b/dev-ros/carrot_planner/Manifest
index 33bc396e0d62..b79af5c507b2 100644
--- a/dev-ros/carrot_planner/Manifest
+++ b/dev-ros/carrot_planner/Manifest
@@ -1,4 +1,6 @@
DIST navigation-1.15.1.tar.gz 346480 BLAKE2B 29f9a0b6f2c62bd21a7cb87a64b490c845bb7db4af338fd094744abb22402df7eedc8c164b64f93f2d67dabaff99ca3b946b45e93173bed74834d9e3668726ad SHA512 25c5093bf7acca9d15d46bb2d0ae7e4ce0fa45f18b32d1626668dcbd33732317e8535b978e7225d86391472c517f05acb7736f31a7c511c8736ab8a22c7af4b0
+DIST navigation-1.15.2.tar.gz 348985 BLAKE2B 866779425828b1e4c3a044654ae41f33643646ca70cf6841f23bce265add2c420bf0934a41a6b29fa65fc421228a31dc15e9fb0f6cc4295ce12adbbb627b43d4 SHA512 582422756b31b4d83e929e3c723e7205e772b9775fcf618c9bd5d3c54af1f20e9bc8a0143626750c0c3cffeb0cbea8f8706b7e66f62dc037cfe12b05f23ee142
EBUILD carrot_planner-1.15.1-r1.ebuild 541 BLAKE2B 7020abbceb184d865ec76725b26d9cff22a1275b4b69657ad0283c56eb3e1bea75d04cb077457fe01f4b1406722c32e9d4a4ebe419d170ab9d494a9166256437 SHA512 e2a009858721c857e397112f235349807262897a34e91c7651972d1a7384e103704e80fa24a90b351eb2579373052ed9d29415b80cbf7042675409a5ef87c7d7
+EBUILD carrot_planner-1.15.2.ebuild 541 BLAKE2B 5d89690fc8f307ba8da75ad866ca06df0f401119de9322318bd32061969d54429dec6d971e5016b968d01a2506b94f253c3737fa3219ef1d7d43fdfb980b42ea SHA512 53b8e7a89844cc5dcb60863110b2dc097696ccd7a663c796d135b5912eb89c4c0747cc3afdf4358a6e464b5c7c1d4a1d7cda4fae2470cb9643a48512cc03d9a6
EBUILD carrot_planner-9999.ebuild 541 BLAKE2B 7020abbceb184d865ec76725b26d9cff22a1275b4b69657ad0283c56eb3e1bea75d04cb077457fe01f4b1406722c32e9d4a4ebe419d170ab9d494a9166256437 SHA512 e2a009858721c857e397112f235349807262897a34e91c7651972d1a7384e103704e80fa24a90b351eb2579373052ed9d29415b80cbf7042675409a5ef87c7d7
MISC metadata.xml 337 BLAKE2B ecfbf3d0b63a1b876065d04b3d52daa0442e3bcaf060836731012a1e698b3aea06ff292d892035feb2fb0fc257d6d8462d013ccc67f2650177c9cdba4d051d44 SHA512 f5df7464100fa15a3d2ad11cc620007500a5cb5ea7be67ac45819a541dd4ae53ce476231d475acf4dfe7e7bf0c31281325dc4e003867d1cc01a29353bb5ea09e
diff --git a/dev-ros/carrot_planner/carrot_planner-1.15.2.ebuild b/dev-ros/carrot_planner/carrot_planner-1.15.2.ebuild
new file mode 100644
index 000000000000..3f5f3f231f33
--- /dev/null
+++ b/dev-ros/carrot_planner/carrot_planner-1.15.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Attempts to find a legal place to put a carrot for the robot to follow"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/nav_core
+ dev-ros/costmap_2d
+ dev-ros/base_local_planner
+ dev-ros/pluginlib
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}"