summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-01 19:11:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-01 19:11:24 +0100
commit0a772e9952c6683769ac22be1b2304fcd86f02cb (patch)
tree913ccfa8988bae59ab9651b5b9a20e1265157f7d /dev-python
parent8598ab9ad325d12d0f2901ecc0973e430dacd2b3 (diff)
gentoo auto-resync : 01:10:2022 - 19:11:24
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Manifest.gzbin260933 -> 260930 bytes
-rw-r--r--dev-python/coverage/Manifest2
-rw-r--r--dev-python/coverage/coverage-6.5.0.ebuild73
-rw-r--r--dev-python/ensurepip-setuptools/Manifest2
-rw-r--r--dev-python/ensurepip-setuptools/ensurepip-setuptools-65.4.1.ebuild27
-rw-r--r--dev-python/pyqtgraph/Manifest2
-rw-r--r--dev-python/pyqtgraph/pyqtgraph-0.13.1.ebuild73
-rw-r--r--dev-python/pytest-cov/Manifest2
-rw-r--r--dev-python/pytest-cov/pytest-cov-4.0.0.ebuild61
-rw-r--r--dev-python/rapidfuzz/Manifest2
-rw-r--r--dev-python/rapidfuzz/rapidfuzz-2.10.3.ebuild45
-rw-r--r--dev-python/setuptools/Manifest2
-rw-r--r--dev-python/setuptools/setuptools-65.4.1.ebuild127
13 files changed, 418 insertions, 0 deletions
diff --git a/dev-python/Manifest.gz b/dev-python/Manifest.gz
index f75dc958c584..2dbb018a1cea 100644
--- a/dev-python/Manifest.gz
+++ b/dev-python/Manifest.gz
Binary files differ
diff --git a/dev-python/coverage/Manifest b/dev-python/coverage/Manifest
index 364a8f51edc8..a1e63925d02b 100644
--- a/dev-python/coverage/Manifest
+++ b/dev-python/coverage/Manifest
@@ -1,3 +1,5 @@
DIST coverage-6.4.4.tar.gz 772949 BLAKE2B 87b4c51ac43ac3bd2202496f6db6de5c74dd9925521bf3092cd862b86d8d7c0e3d008ee550c90e890febd87cc4d167669e830668f15da94ef4ea72e82154bf26 SHA512 f210f2471b170e05d4dac2cc9a91e3f0d4ba6456cdf91dc1c0ef67a02a11f4279c5beca5df8854c42660346995492b1eff020e1ac578d2a0a129627dadd17114
+DIST coverage-6.5.0.tar.gz 775224 BLAKE2B 1ff7db1c72856553717d07d5a13443c210a3d85b3ce1f1eee802b986f71e3c13ac9df6bbca498fbeaa961ee33baab29c5e38f0c0e7b21c378830dfe85d797798 SHA512 4f2ec0bf69a83471a2b5a73b6a2212372ee6e32ccc4c72e0d33eef915939152f3213ab60e1a22ce2b72791e706c2223b0c81c87b95bbfadd1e828fa1a9fff120
EBUILD coverage-6.4.4.ebuild 1678 BLAKE2B c7e457ab2b0d46e6550793f295ee6294b70f099aa0c6be6a3a3a8505cfd8dc8dce1270b550dd6a73c838d4aaea0c99d20c12c6fdab32bc05e62e45c902df6275 SHA512 a9a31b2d0883fb30bf389104f9d884313bb6906bc71f8093931021f7c9c5e441304ae536a33c2948c5df69a45532dad6ff9c531533ff23511853901d7d8ec224
+EBUILD coverage-6.5.0.ebuild 1799 BLAKE2B 74ac7ba94fc20a48efe45b9269ce17cd5de9cf73fa3203b3525993b665279f76cce974c88e91d9768d918524db3a4d90153f8281be148e5410be1ca4cb0ced6d SHA512 d36cb0a78490a8fd9de11d832aa5ad1b7635f6d68ea7e3d56f397c28b33b577b56d5a06ad90e051eaabb972e211d0fe315d23545785b5e79d5a08d9f719ec4ef
MISC metadata.xml 714 BLAKE2B c0d2641f795a21a80b6fa36206973f41421effe055e4c5e41bf752869759eb48e8fe42a0ab00af55b5d5111bfaccd330676d63e263013dc9bd3c344cb038a3a6 SHA512 412d70b7c9c2871bb93ae6ed6ae110a9f29c26957f6e1b24cc531c7d49f292ecb5206df10b409f2e44d2f814b119ef4ed973bca608df999026bda8df2156df24
diff --git a/dev-python/coverage/coverage-6.5.0.ebuild b/dev-python/coverage/coverage-6.5.0.ebuild
new file mode 100644
index 000000000000..e2e5a9ba699a
--- /dev/null
+++ b/dev-python/coverage/coverage-6.5.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Code coverage measurement for Python"
+HOMEPAGE="
+ https://coverage.readthedocs.io/en/latest/
+ https://github.com/nedbat/coveragepy/
+ https://pypi.org/project/coverage/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ >=dev-python/unittest-mixins-1.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/^addopts/s:-q -n auto::' setup.cfg || die
+ distutils-r1_src_prepare
+}
+
+test_tracer() {
+ local -x COVERAGE_TEST_TRACER=${1}
+ einfo " Testing with the ${COVERAGE_TEST_TRACER} tracer ..."
+ epytest tests
+}
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # pip these days insists on fetching build deps from Internet
+ tests/test_venv.py
+ )
+
+ "${EPYTHON}" igor.py zip_mods || die
+
+ local -x COVERAGE_TESTING=True
+ # TODO: figure out why they can't be imported inside test env
+ local -x COVERAGE_NO_CONTRACTS=1
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=_hypothesis_pytestplugin,flaky.flaky_pytest_plugin,xdist.plugin
+
+ local prev_opt=$(shopt -p nullglob)
+ shopt -s nullglob
+ local c_ext=( "${BUILD_DIR}/install$(python_get_sitedir)"/coverage/*.so )
+ ${prev_opt}
+
+ if [[ -n ${c_ext} ]]; then
+ cp "${c_ext}" \
+ coverage/ || die
+ test_tracer c
+ rm coverage/*.so || die
+ else
+ test_tracer py
+ fi
+}
diff --git a/dev-python/ensurepip-setuptools/Manifest b/dev-python/ensurepip-setuptools/Manifest
index f1c5568e511d..ad1f4f570d88 100644
--- a/dev-python/ensurepip-setuptools/Manifest
+++ b/dev-python/ensurepip-setuptools/Manifest
@@ -1,7 +1,9 @@
DIST setuptools-65.0.2-py3-none-any.whl 1233332 BLAKE2B 0c0d0db73452d15947097f3d453f01bb42ef150b50122b7a1f39212f663064284bc313a04c3dbe99e8da7e614d72a963d6c9f0c8f486f5d84131a06718b288c8 SHA512 11d9975468166bf7db9a9da44d893a67daacc5f309da1b521278a95a33fa2b3574cae10840c9943de54bf5d411e54697f91b62a3bfb5a6a3bc69b804af2a1365
DIST setuptools-65.1.0-py3-none-any.whl 1232689 BLAKE2B db8f85b99b1d47af55d484d77ecafe5122abe9ab8dcec565659bb91c16aa26513c00d8684ca3b7b57e629d512b42273188a00ee0a0958bba5097ce150869609f SHA512 1072a826964ec3413c5bcd3f930a2f314b87b0b77714ddc948573841fbb871a898843211beaff0bcc5e003fcaab678de5d2b9a3a9fa864beced1bf2af282d048
DIST setuptools-65.2.0-py3-none-any.whl 1232422 BLAKE2B 049fbccec71e15ed01b5e07f5d60589c662d012e4fe27c6eb8fbe3b62692bb63d891c9cf4253fe74b5a5803db39f3e5194f8481e5a3555493e9f18bd6985b35d SHA512 e0fc48a3ebe2022783c2f56d85d8ad5e17bd0f5f2caefc5e3ac6eb4ddf1464854ad9039c62a55e72ca6b0387e7f874b15b7a0df4acbf6153a51cb8e8146bd93d
+DIST setuptools-65.4.1-py3-none-any.whl 1232518 BLAKE2B 545caa5f7c551090e3dcb71c388477c4aad8aaee1dbf4a7f7fc08f27a296a81a055310b41c3d4af7cb3cf375c5ab465fec29ef3e29456281f56b7df544dd0eca SHA512 c0bc3f5f3b7c8a8b83df4d12f5f99d41ea910220abc16e8b93e3b533dc8d665802608c447e8c1eb070c19c24b1baa83faf2ac42488f95808ed585c169afadd58
EBUILD ensurepip-setuptools-65.0.2.ebuild 627 BLAKE2B f9effdc2c370edaacfe107c69a461aea1d737b5134c35647f4cff0919f577099ab7e59423f9eae9d0bf48bb04efa8ffae91a797176b485501ab68ba991a8e126 SHA512 79952939def604a65c67c39b61938c7c24e644c4c841c1d466a2a8d6030d4a942213365c7389612edbd43df5db0df113ea8f6da7b62ff5681819f0de9cb11c0e
EBUILD ensurepip-setuptools-65.1.0.ebuild 627 BLAKE2B f9effdc2c370edaacfe107c69a461aea1d737b5134c35647f4cff0919f577099ab7e59423f9eae9d0bf48bb04efa8ffae91a797176b485501ab68ba991a8e126 SHA512 79952939def604a65c67c39b61938c7c24e644c4c841c1d466a2a8d6030d4a942213365c7389612edbd43df5db0df113ea8f6da7b62ff5681819f0de9cb11c0e
EBUILD ensurepip-setuptools-65.2.0.ebuild 620 BLAKE2B cdb59a7448ad7ba64fe903fe3f8cdf7f697c5e36d225557b1f656c1e16f54d12a778ef2ecabb92bfe1015f785ff62ed6a431294cbcf316dd24364f46baa11e2e SHA512 a924f4bccd7ef3d613a0ed51443b9eed6f3b2aa432ccc428c12661d150e3cb937cb9340f956920878b0b27a5f65e0220de7ca252ff008504020c02a4f2438b71
+EBUILD ensurepip-setuptools-65.4.1.ebuild 627 BLAKE2B f9effdc2c370edaacfe107c69a461aea1d737b5134c35647f4cff0919f577099ab7e59423f9eae9d0bf48bb04efa8ffae91a797176b485501ab68ba991a8e126 SHA512 79952939def604a65c67c39b61938c7c24e644c4c841c1d466a2a8d6030d4a942213365c7389612edbd43df5db0df113ea8f6da7b62ff5681819f0de9cb11c0e
MISC metadata.xml 316 BLAKE2B 17947c657b45cb01758e222aa6051a459bf0bd9a026a73c0df0ae0c3a0c901f6e2315d459ee37036ecd283481a8d97791d64688c108a0706e745a739e3f9e8f8 SHA512 af18f4ae51b253552752e14210789988c815d0dbf0e1d8ff7057e48a09303c4abc1fb240d6f7f15fc0993b33e4c8ee395c2755754b3a2cbfd4c3a3f0dad41cfe
diff --git a/dev-python/ensurepip-setuptools/ensurepip-setuptools-65.4.1.ebuild b/dev-python/ensurepip-setuptools/ensurepip-setuptools-65.4.1.ebuild
new file mode 100644
index 000000000000..96c75c915768
--- /dev/null
+++ b/dev-python/ensurepip-setuptools/ensurepip-setuptools-65.4.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN=${PN#ensurepip-}
+WHL=${MY_PN}-${PV}-py3-none-any.whl
+
+DESCRIPTION="Shared setuptools wheel for ensurepip Python module"
+HOMEPAGE="https://pypi.org/project/setuptools/"
+SRC_URI="
+ https://files.pythonhosted.org/packages/py3/${MY_PN::1}/${MY_PN}/${WHL}
+"
+S=${DISTDIR}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ !<dev-python/ensurepip-wheels-100
+"
+
+src_install() {
+ insinto /usr/lib/python/ensurepip
+ doins "${WHL}"
+}
diff --git a/dev-python/pyqtgraph/Manifest b/dev-python/pyqtgraph/Manifest
index c704d8e6947a..9472d6b42651 100644
--- a/dev-python/pyqtgraph/Manifest
+++ b/dev-python/pyqtgraph/Manifest
@@ -1,4 +1,6 @@
DIST pyqtgraph-0.12.4.tar.gz 1333052 BLAKE2B 4208787d1d203904d841493e10b2f1d23357b60475c9e1cfff733fe772973d4dd619ca84941049bd60299912f3077fb18c27a90fa3c0c0e712a3715b5be1d071 SHA512 8402b38fe1abaaf55d6dbc26775093993b9f642d7a9da59d2780ed38562c8653ab872c588d2e66373434491b8f397533cb3c222382065c812a28cf6b9ce34960
+DIST pyqtgraph-0.13.1.gh.tar.gz 1368154 BLAKE2B cb19ae6564b0fc0a4ec4fb6232f7949bb5130345380a86f0cffdee14e767d306b27c26ae3f7c011d77f21353b511d99148e1acb38e8d33598dde16362475b5a8 SHA512 bcd3d0c9c1d91ad2ea3f85f8e34e68ab999fce636ed336362253f09a7863a62c4b635d71c137c9458532c7d1f76dfc8433d476cd84121cf89488fb0860039b8f
DIST pyqtgraph-test-data-8.tar.gz 306068 BLAKE2B f3aa418dfaf2e74950fa880da4b6dfb4ef5dbd46346b78065d885c1f9fc06fc3de86756af17e27035d4cd47d98cc7ce58c036b493837b568086a4ebceb230c78 SHA512 07ef414f2b57e00589f8c18459e88ab16001c7cc3766164cdfcd69faa26cbc90ed64611fd0c5e3b401dc6a3f1a6e9e4ce6a7d9fa96ebcc4360e03fa9fbb856d2
EBUILD pyqtgraph-0.12.4.ebuild 2391 BLAKE2B 2da730487e4382d60ed2563956df1fa4df0980fb52e57408fdf8c9ee828dc7795e1d21833d852fcc1d6968381da49f51152ed4dd59ba901e68c2e69dea9eab43 SHA512 5a048f86d61b380cd9aa92c4419d86397c9abb8575fd585bebada0e0ddcc14975fc65ebe2a8254d235370e14882ade681d94f7dc4988ff16dbaf3831d0518824
+EBUILD pyqtgraph-0.13.1.ebuild 1793 BLAKE2B e2a4bb5659d1ae5e78d64299b0e9665aae2e6a68a5e84665c9df26c690a27882a92b2d2460badbdb0a6af5f1a7ba5fd435ab8a9e2d95dc3b801516e97a36fdd9 SHA512 327a38c617fd0775b2267172a1558bef064e4fc521de8da4a80567b316ddef6e3c3d394cada78c2849c0f345e1bb0f2dce79855d55f952f88ab6daedc3059826
MISC metadata.xml 775 BLAKE2B 08f1417793ef0b57d978cab5b4c03e43e756a43625d8e6173a8b74d3c9dcce0547934485d192546cf81b8da03bdf21e4c800bb25e0bec452fe092ab3772a518f SHA512 b03a0aa3f6e6183ef2d81b9d0bb22f576661b353986a802f01cb670f9ae0487d84d3e91fd0a4add41e3dd830dbbc0414f4d556bc05bb89a768be9e5c2cee4ce4
diff --git a/dev-python/pyqtgraph/pyqtgraph-0.13.1.ebuild b/dev-python/pyqtgraph/pyqtgraph-0.13.1.ebuild
new file mode 100644
index 000000000000..ef091c06b4da
--- /dev/null
+++ b/dev-python/pyqtgraph/pyqtgraph-0.13.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="A pure-python graphics and GUI library built on PyQt and numpy"
+HOMEPAGE="
+ https://www.pyqtgraph.org/
+ https://github.com/pyqtgraph/pyqtgraph/
+ https://pypi.org/project/pyqtgraph/
+"
+SRC_URI="
+ https://github.com/pyqtgraph/pyqtgraph/archive/${P}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S=${WORKDIR}/${PN}-${P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="opengl svg"
+REQUIRED_USE="test? ( opengl svg )"
+
+RDEPEND="
+ >=dev-python/numpy-1.17[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/PyQt5[gui,widgets,opengl=,svg=,${PYTHON_USEDEP}]
+ opengl? ( dev-python/pyopengl[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ test? (
+ dev-python/h5py[${PYTHON_USEDEP}]
+ dev-python/PyQt5[testlib,${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/pytest-xvfb[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+distutils_enable_sphinx doc/source
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ if ! use opengl; then
+ rm -r pyqtgraph/opengl || die
+ fi
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # apparently fragile
+ tests/test_reload.py::test_reload
+
+ # TODO
+ tests/graphicsItems/test_ROI.py::test_PolyLineROI
+
+ # pyside2 is normally skipped if not installed but these two
+ # fail if it is installed
+ # TODO: this could be due to USE flags, revisit when pyside2
+ # gains py3.9
+ 'pyqtgraph/examples/test_examples.py::testExamples[ DateAxisItem_QtDesigner.py - PySide2 ]'
+ 'pyqtgraph/examples/test_examples.py::testExamples[ designerExample.py - PySide2 ]'
+ )
+
+ epytest -p xvfb -n "$(makeopts_jobs)"
+}
diff --git a/dev-python/pytest-cov/Manifest b/dev-python/pytest-cov/Manifest
index 558f3cffc5a0..415f616e3569 100644
--- a/dev-python/pytest-cov/Manifest
+++ b/dev-python/pytest-cov/Manifest
@@ -1,4 +1,6 @@
AUX pytest-cov-3.0.0-coverage-6.2.patch 1034 BLAKE2B 433d761faae7c929b09e6d7a346fa1129acb427939756efa4d465ed6a6a20fb45ad09f890ce9d9b95c45862bc072a20d9038a1acca06de1963008119188b3e87 SHA512 85501e1c16f9716a3c2b04c79786e657e71ed58a6b0d338458e4cd17abff19eb85dd4b4c6d427e5f17d259d8ce970e79682c613a51b252cd506b1cd895fd8ee6
DIST pytest-cov-3.0.0.tar.gz 61440 BLAKE2B 85f0b079c4c373191553271e34e78af68ac69ea53e3721aa0d43eb9dd55be935570eb15c0f8b954e4c0de6201c004ddef435ea70b03cfda893ecdcc230c283e7 SHA512 289d1b1e29dcc3461276de4c1bbd3884e4ec957efb7dd4c330bc3f25f1b978cbee64c0e2882b419eee5f9ccf44c9d1a23ce47a1b7cc7e436b9ebe894e4c11ae8
+DIST pytest-cov-4.0.0.tar.gz 62013 BLAKE2B af8a12955e3f22cd9dc257874f86c04c3c6e29f4af2d2838f37ca196c4955dcf4007c7b404f31c303d0eef6c3735fa1a6268c3bb9f01ed54860750ca2f83b6f5 SHA512 fb993be4d86b29a44e4f2ccd2309d99ab9fe8e6b291abbc2a8a3fc8b36479491165a242a20bfa9886dfd296fcc827da9984b556fdbe9a3ac496ac5b6ba379012
EBUILD pytest-cov-3.0.0-r1.ebuild 1704 BLAKE2B 873030ba19d725b309861ee7ea02b8e54d680100aab0239c5efb66eee251d15c0a8dd0f2f948121173dc906aed99d2476df0250d3e9fd13e1a2dcc5f56ca1925 SHA512 bea2d3fbe99347972bcc22c566365b0322e97a30f31fe71ec4c78670d8875e9040bb69c85d41840da1f67e4e4e30cdc496e816624b1aa748eaf8f16708a4386d
+EBUILD pytest-cov-4.0.0.ebuild 1659 BLAKE2B d542d52ee2d6b1d171f6c30c63096a3ab0e356982b6bfce851ce3d6786a2594fcd06777931829c72244035fea1f4d8ca95d70718bf4c392f53caf259a09126cc SHA512 ed1da34ac0e2d83413e2257419d2c92b4099f90df9adba3e4bf946c9834c6a6488baa2d4e2f5cbca988ab4f8478dfa0ee16fd726d81012bbbb929dd45e30d30f
MISC metadata.xml 412 BLAKE2B 0d79131c6fd8adf72493a7c333959e065cf4f2231f6c770800b6d05ff9afcc246cd202406bea6e28f6b0fd23ee6197aa8dac2dd59d0a89d9b07741f57e8fa5e8 SHA512 d1aab9ea8042bf810398a4195fd3595a8abbeb060ab38fd7b7e40085c8d5f22ecb78bab02e2331d4588199d88e0d3848413d75a18fe4373ecd9940a3c990c604
diff --git a/dev-python/pytest-cov/pytest-cov-4.0.0.ebuild b/dev-python/pytest-cov/pytest-cov-4.0.0.ebuild
new file mode 100644
index 000000000000..00e9dce47cda
--- /dev/null
+++ b/dev-python/pytest-cov/pytest-cov-4.0.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin for coverage reporting"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-cov/
+ https://pypi.org/project/pytest-cov/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/py-1.4.22[${PYTHON_USEDEP}]
+ >=dev-python/pytest-3.6[${PYTHON_USEDEP}]
+ >=dev-python/coverage-4.4[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ dev-python/fields[${PYTHON_USEDEP}]
+ >=dev-python/process-tests-2.0.2[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx-py3doc-enhanced-theme
+distutils_enable_tests pytest
+
+python_test() {
+ # NB: disabling all plugins speeds tests up a lot
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_cov.plugin,xdist.plugin,xdist.looponfail
+
+ local EPYTEST_DESELECT=(
+ # attempts to install packages via pip (network)
+ tests/test_pytest_cov.py::test_dist_missing_data
+ # TODO
+ tests/test_pytest_cov.py::test_contexts
+ )
+
+ # TODO: why do we need to do that?!
+ # https://github.com/pytest-dev/pytest-cov/issues/517
+ ln -s "${BROOT}$(python_get_sitedir)/coverage" \
+ "${BUILD_DIR}/install$(python_get_sitedir)/coverage" || die
+
+ epytest
+
+ rm "${BUILD_DIR}/install$(python_get_sitedir)/coverage" || die
+}
diff --git a/dev-python/rapidfuzz/Manifest b/dev-python/rapidfuzz/Manifest
index 35294e9ac1a5..f54cc06d6005 100644
--- a/dev-python/rapidfuzz/Manifest
+++ b/dev-python/rapidfuzz/Manifest
@@ -1,3 +1,5 @@
DIST rapidfuzz-2.10.2.tar.gz 788167 BLAKE2B 91264d83159ce91cac33138c2589d468ffb079daef06f1917596892b3c5fbb99f2012d79ca05f728e6d49c2241d83f68e0d3a44956cfdfafd38cae428496f507 SHA512 3d7610a2e4b32fbfaa0ac043847829bfc436e61c2d0c76d526fc0827cca4fd10a0b6ae659bd61ed48604695c4782bcb0984d2becaf84494b84a5d8e71c22e97a
+DIST rapidfuzz-2.10.3.tar.gz 788237 BLAKE2B dd6e70bd1059317d98cf96c242e62ba8be2c9bdeac483f0da18b4f46179502ac0f0ae000f5bdfedc44374dceae1c4054bd2a6be7dde5e466497c617c699ceeeb SHA512 9774a203482ab90a4bdc7f9faaa2ea0c0c314e350fb6c957c3eed3f7cb5009d1fd2521c5438b25d8d04aedf96028004136908a3226305bd2cbcf4158d0bc0329
EBUILD rapidfuzz-2.10.2.ebuild 1051 BLAKE2B 7e05388be109cbfeff7d033a7e09acb9706dab76a0a46db9c1c8b21619e29f00452f658e50b2da8c05338ceed23761698efbc72bffd19a9ad9e1cf5df11c53b7 SHA512 d21721f9424c49870a7fe2f68577b7f068210686ef0cd84d54b3a93c05b3c6d17929e6acae6155d8afa38b02e6e0f21d8c4883705caf677df48f5ca526baa44d
+EBUILD rapidfuzz-2.10.3.ebuild 1051 BLAKE2B 7e05388be109cbfeff7d033a7e09acb9706dab76a0a46db9c1c8b21619e29f00452f658e50b2da8c05338ceed23761698efbc72bffd19a9ad9e1cf5df11c53b7 SHA512 d21721f9424c49870a7fe2f68577b7f068210686ef0cd84d54b3a93c05b3c6d17929e6acae6155d8afa38b02e6e0f21d8c4883705caf677df48f5ca526baa44d
MISC metadata.xml 374 BLAKE2B e6ee89a9850276b8c22c9bc851ebea2cde2ea696d122d70c6465e09a9371c59f81d1976b3253e8ee90afae5e3e30e993481b402058bac0c58ec01f71a0b7c3b4 SHA512 9a39c4bcf8e8de0a6d6a356a9aeb415f8f49667caf5716eee50bf251f1fd53bb076e817fac0b15bf64e65c1b9625c78810da61a5d96b273a20b2669a18084d6e
diff --git a/dev-python/rapidfuzz/rapidfuzz-2.10.3.ebuild b/dev-python/rapidfuzz/rapidfuzz-2.10.3.ebuild
new file mode 100644
index 000000000000..3a1dc1af36a6
--- /dev/null
+++ b/dev-python/rapidfuzz/rapidfuzz-2.10.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# custom wrapper over setuptools
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Rapid fuzzy string matching in Python using various string metrics"
+HOMEPAGE="
+ https://github.com/maxbachmann/RapidFuzz/
+ https://pypi.org/project/rapidfuzz/
+"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ <dev-python/jarowinkler-2[${PYTHON_USEDEP}]
+ >=dev-python/jarowinkler-1.2.2[${PYTHON_USEDEP}]
+"
+# all these are header-only libraries
+DEPEND="
+ >=dev-cpp/taskflow-3.0.0
+ >=dev-cpp/jarowinkler-cpp-1.0.0
+ >=dev-cpp/rapidfuzz-cpp-1.0.1
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/rapidfuzz_capi[${PYTHON_USEDEP}]
+ >=dev-python/scikit-build-0.13.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export RAPIDFUZZ_BUILD_EXTENSION=1
diff --git a/dev-python/setuptools/Manifest b/dev-python/setuptools/Manifest
index 1bd385427409..4286b4227001 100644
--- a/dev-python/setuptools/Manifest
+++ b/dev-python/setuptools/Manifest
@@ -1,6 +1,8 @@
AUX setuptools-62.4.0-py-compile.patch 3704 BLAKE2B 9a5e70d2556b059be0ef060abd1db71298cd0e9aa1e2795d92cea5cdbaf0c82f4433e1a0c3095f4bc41bc72a457b63142253fe46c712afa1d7855a5d43607bca SHA512 48d7c065e2d8c29ce6e498effe6d79f9caa0f37d7cf6cadd0ed02c48d196a4d8a10a73cfa26744d6f74b48c63cd28a4074b161a6aae18c6169f6d8fffb044b1e
DIST setuptools-65.3.0.tar.gz 2615722 BLAKE2B 1344fe17c1c2a4ec60dbf37b3e1cbad56bb5299bed9f8e30a21015f2457e1e90d6782369dfc2d804973e7348d22a356ec0ef75d1aeabba7d77e20e5ddf36e576 SHA512 3c173b1e1a8dbbed0bf3bf600df1256aeabf1b9dec34d5f5d0b1429b0fe16f2aa61fa6c4f400a5b6da24b9d679954866b76e019130bcf2246b138fe017025de9
DIST setuptools-65.4.0.tar.gz 2615629 BLAKE2B 778b0acf1a447fbc72043113da757d73ca5dc0df8e6be8dceff7e35d64a920793dca6098d8747bd66bfe1159236570bffb6f2545a0f89a2a7916f94f849b89a7 SHA512 4c8c6348fc5e9e2cc2d7b143b050103e7ed4252dd58ca5aae8d50ee9ec522789ecfbe61dd87513d47bfd1d4afc290a7abc07fd0a6e8d27155c6732111702032d
+DIST setuptools-65.4.1.tar.gz 2615710 BLAKE2B 12e644412c7f910a8bf6fb470e0c7e78bcd11a9403d7d0821eecad156d0a4ed03751de6bd6c51ebc2ce1c0925386120971c0da129ebd7e1b8376feee1f8edc7e SHA512 d13253bb556380b1b45d4b51dc7922b0cffa390ba92d97ccbc43c314aceccdcf51ee8b5c751cf6f36c6c8955836bc248214d55fe7419ff0332719862772f0f95
EBUILD setuptools-65.3.0.ebuild 4261 BLAKE2B 3ee99d3763734ce401eca631ec21f1dc0497b9d9216569ee1f9decdbdbe59668a17a271a0db8fe7f1c646b3eef26772c3aa0b394839920ae9ce9d80e16fe31c2 SHA512 9c748d867f71d7c7c8eda664cd5a11c75d13cf1e82928ac9ef9a4fc3984208f1d9439941016dded058cc63f446b14099b99b86e3cd9055e2365c5b482ee24a74
EBUILD setuptools-65.4.0.ebuild 4269 BLAKE2B 5df1501305bd2717a5671d8e0d9ec0b0f9b5da733e09d54858884ea3ef1fe0d1444f476295c8a42133e566e9db836d8ccc3be8709b6a35a9a02ab2c3a7a0e1a5 SHA512 3fbf979376dfe61f354af1b80d452203161411eb0538ccc1138852aa5daeac044af3a5a579a1c0f0beec41df16414af0b0f0c25c06a265a36c6e076ee3614fc6
+EBUILD setuptools-65.4.1.ebuild 4269 BLAKE2B 5df1501305bd2717a5671d8e0d9ec0b0f9b5da733e09d54858884ea3ef1fe0d1444f476295c8a42133e566e9db836d8ccc3be8709b6a35a9a02ab2c3a7a0e1a5 SHA512 3fbf979376dfe61f354af1b80d452203161411eb0538ccc1138852aa5daeac044af3a5a579a1c0f0beec41df16414af0b0f0c25c06a265a36c6e076ee3614fc6
MISC metadata.xml 469 BLAKE2B 4a26769b09a3785586b22db850b7fc5c4818f31c3ace9cc94476d35df05e50edf6721f3c95ec615c3b2efe071ef284a54ea2d53566316ba653f7830bb48f80bf SHA512 dd682c4ad2e59a97094ebdabe4d1063e2319ed05e1fe9d8c2fafe069badb3b4cf8bb6d9f50e09d2128e2a081c1c69827407ac8aed644ebf70eb4ca1bc9a57319
diff --git a/dev-python/setuptools/setuptools-65.4.1.ebuild b/dev-python/setuptools/setuptools-65.4.1.ebuild
new file mode 100644
index 000000000000..c11a0923e907
--- /dev/null
+++ b/dev-python/setuptools/setuptools-65.4.1.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+# please bump dev-python/ensurepip-setuptools along with this package!
+
+DISTUTILS_USE_PEP517=standalone
+PYTHON_TESTED=( python3_{8..11} pypy3 )
+PYTHON_COMPAT=( "${PYTHON_TESTED[@]}" )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Collection of extensions to Distutils"
+HOMEPAGE="
+ https://github.com/pypa/setuptools/
+ https://pypi.org/project/setuptools/
+"
+SRC_URI="
+ mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos ~x64-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/appdirs-1.4.4-r2[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-text-3.7.0-r1[${PYTHON_USEDEP}]
+ >=dev-python/more-itertools-8.12.0-r1[${PYTHON_USEDEP}]
+ >=dev-python/nspektr-0.3.0[${PYTHON_USEDEP}]
+ >=dev-python/ordered-set-4.0.2-r1[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.3-r2[${PYTHON_USEDEP}]
+ >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_metadata-4.11.1[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_resources-5.4.0-r3[${PYTHON_USEDEP}]
+ ' 3.8)
+"
+BDEPEND="
+ ${RDEPEND}
+ >=dev-python/wheel-0.37.1-r1[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/build[${PYTHON_USEDEP}]
+ >=dev-python/ini2toml-0.9[${PYTHON_USEDEP}]
+ >=dev-python/filelock-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-envs-2.2[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-path-3.2.0[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/pip-run[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-fixture-config[${PYTHON_USEDEP}]
+ dev-python/pytest-virtualenv[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ >=dev-python/tomli-w-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-20[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ ' "${PYTHON_TESTED[@]}")
+ )
+"
+PDEPEND="
+ >=dev-python/certifi-2016.9.26[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+"
+
+DOCS=( {CHANGES,README}.rst )
+
+src_prepare() {
+ local PATCHES=(
+ # TODO: remove this when we're 100% PEP517 mode
+ "${FILESDIR}"/setuptools-62.4.0-py-compile.patch
+ )
+
+ # remove bundled dependencies, setuptools will switch to system deps
+ # automatically
+ rm -r */_vendor || die
+
+ # remove the ugly */extern hack that breaks on unvendored deps
+ rm -r */extern || die
+ find -name '*.py' -exec sed \
+ -e 's:from \w*[.]\+extern ::' -e 's:\w*[.]\+extern[.]::' \
+ -i {} + || die
+
+ distutils-r1_src_prepare
+
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+}
+
+python_test() {
+ local -x SETUPTOOLS_USE_DISTUTILS=stdlib
+
+ if ! has "${EPYTHON}" "${PYTHON_TESTED[@]/_/.}"; then
+ return
+ fi
+
+ local EPYTEST_DESELECT=(
+ # network
+ # TODO: see if PRE_BUILT_SETUPTOOLS_* helps
+ setuptools/tests/config/test_apply_pyprojecttoml.py::test_apply_pyproject_equivalent_to_setupcfg
+ setuptools/tests/integration/test_pip_install_sdist.py::test_install_sdist
+ setuptools/tests/test_build_meta.py::test_legacy_editable_install
+ setuptools/tests/test_distutils_adoption.py
+ setuptools/tests/test_editable_install.py
+ setuptools/tests/test_setuptools.py::test_its_own_wheel_does_not_contain_tests
+ setuptools/tests/test_virtualenv.py::test_clean_env_install
+ setuptools/tests/test_virtualenv.py::test_no_missing_dependencies
+ setuptools/tests/test_virtualenv.py::test_test_command_install_requirements
+ # TODO
+ setuptools/tests/config/test_setupcfg.py::TestConfigurationReader::test_basic
+ setuptools/tests/config/test_setupcfg.py::TestConfigurationReader::test_ignore_errors
+ setuptools/tests/test_extern.py::test_distribution_picklable
+ # expects bundled deps in virtualenv
+ setuptools/tests/config/test_apply_pyprojecttoml.py::TestMeta::test_example_file_in_sdist
+ setuptools/tests/config/test_apply_pyprojecttoml.py::TestMeta::test_example_file_not_in_wheel
+ setuptools/tests/test_editable_install.py::test_editable_with_pyproject
+ )
+
+ epytest -n "$(makeopts_jobs)" setuptools
+}