summaryrefslogtreecommitdiff
path: root/dev-python/ensurepip-setuptools/ensurepip-setuptools-65.4.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ensurepip-setuptools/ensurepip-setuptools-65.4.1.ebuild')
-rw-r--r--dev-python/ensurepip-setuptools/ensurepip-setuptools-65.4.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/ensurepip-setuptools/ensurepip-setuptools-65.4.1.ebuild b/dev-python/ensurepip-setuptools/ensurepip-setuptools-65.4.1.ebuild
new file mode 100644
index 000000000000..96c75c915768
--- /dev/null
+++ b/dev-python/ensurepip-setuptools/ensurepip-setuptools-65.4.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN=${PN#ensurepip-}
+WHL=${MY_PN}-${PV}-py3-none-any.whl
+
+DESCRIPTION="Shared setuptools wheel for ensurepip Python module"
+HOMEPAGE="https://pypi.org/project/setuptools/"
+SRC_URI="
+ https://files.pythonhosted.org/packages/py3/${MY_PN::1}/${MY_PN}/${WHL}
+"
+S=${DISTDIR}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ !<dev-python/ensurepip-wheels-100
+"
+
+src_install() {
+ insinto /usr/lib/python/ensurepip
+ doins "${WHL}"
+}