summaryrefslogtreecommitdiff
path: root/dev-python/wsproto/wsproto-1.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-25 02:49:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-25 02:49:03 +0100
commitca125edb1c8e51bd222fec61eb155151bbd4b791 (patch)
treeb1ca31e2662c41a1e85c62975d23ce38fa0e5df0 /dev-python/wsproto/wsproto-1.2.0.ebuild
parent9d0673651c57438d51e18c6b8ca894d0491b2df3 (diff)
gentoo auto-resync : 25:08:2022 - 02:49:03
Diffstat (limited to 'dev-python/wsproto/wsproto-1.2.0.ebuild')
-rw-r--r--dev-python/wsproto/wsproto-1.2.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/wsproto/wsproto-1.2.0.ebuild b/dev-python/wsproto/wsproto-1.2.0.ebuild
new file mode 100644
index 000000000000..e4c144526888
--- /dev/null
+++ b/dev-python/wsproto/wsproto-1.2.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="WebSockets state-machine based protocol implementation"
+HOMEPAGE="
+ https://github.com/python-hyper/wsproto/
+ https://pypi.org/project/wsproto/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/h11-0.9[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest