summaryrefslogtreecommitdiff
path: root/dev-python/wsproto
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-25 02:49:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-25 02:49:03 +0100
commitca125edb1c8e51bd222fec61eb155151bbd4b791 (patch)
treeb1ca31e2662c41a1e85c62975d23ce38fa0e5df0 /dev-python/wsproto
parent9d0673651c57438d51e18c6b8ca894d0491b2df3 (diff)
gentoo auto-resync : 25:08:2022 - 02:49:03
Diffstat (limited to 'dev-python/wsproto')
-rw-r--r--dev-python/wsproto/Manifest2
-rw-r--r--dev-python/wsproto/wsproto-1.2.0.ebuild26
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/wsproto/Manifest b/dev-python/wsproto/Manifest
index 085ea1546d0b..bab83fce3303 100644
--- a/dev-python/wsproto/Manifest
+++ b/dev-python/wsproto/Manifest
@@ -1,3 +1,5 @@
DIST wsproto-1.1.0.tar.gz 52928 BLAKE2B 837f5d8411a55b026d8c5df8b03b44c92f71fe2856884e5199e639a5c060fabbe8eec39cb6861e8f88ae7fc366cbeef4f9d62dade2c95857d27339fa73e90638 SHA512 0cd726bc62ca4d11e96f470f51511008bd43dbb9e99a17633d2a40da7bdaf19716e0a1c995350f5c8f418f906848dd6f2b9b0a853c1b6858ddafa1cc02fab710
+DIST wsproto-1.2.0.tar.gz 53425 BLAKE2B 0b6bafb5d67be54a9b9c77a9682caf1071e82321fb9112ff977b643956ef5d2d5dcc7e523c6e3038c4548adb7b4f022fe2664112b7a10ab0e183d578158b0711 SHA512 43270687a1cfb5f35423c527de5b9db7ee2ddf27d416f47358386c1c94dc3f836a601f300bf66441c4b90130e6e6f502fb29dfeb2374dd76aefa19cfbb70a372
EBUILD wsproto-1.1.0.ebuild 611 BLAKE2B 60015f4a5f0bd4185e6144e288b4480cf4271a92d3c9900aae381ddaef6ac0cec492568099224084760c700b5c875df28452c9d5bbfa05534dd8ae33776d4828 SHA512 b4e2af51d6a6c3e1ba99ac5b992b5414b70cea6ed05ee6402a986094ab6cab04eb5dbff137f39a30dbb3485543a091dc2dacc9c4c489e830a361e9dad94b34c0
+EBUILD wsproto-1.2.0.ebuild 619 BLAKE2B f4d330a31c31bcad792e354f6bdf883a121000d6b4e888de9fe4579b3fc7abd9a69d29d09dd350969b70441312f1f64ba219fd555e7671ecccd9acee09bb0296 SHA512 6e02771f4c7b3a1ab49cee9b26b7554aa0450b3e73a6b4503ec57cea20342b54178fc1a10ddac2552925d1b4b5ad3e7a7ee4bad606de715f20dc678aa0706bd2
MISC metadata.xml 494 BLAKE2B 144d8a2efbedf70327d0f862e9e1b9d70d8ec72939cea4239e877f183485c9d4075cbadb9423f74b08e8c0ae806b8786467363ff0aae0845be227059e33304ba SHA512 c5818f8c26a0aa8b88b54259ed81c570bee27ca44a20a2f487109477608724f857a306c2b9b82a2a8a03d5852edbfe4ec27f81b60ccf743e58dade14ab992da0
diff --git a/dev-python/wsproto/wsproto-1.2.0.ebuild b/dev-python/wsproto/wsproto-1.2.0.ebuild
new file mode 100644
index 000000000000..e4c144526888
--- /dev/null
+++ b/dev-python/wsproto/wsproto-1.2.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="WebSockets state-machine based protocol implementation"
+HOMEPAGE="
+ https://github.com/python-hyper/wsproto/
+ https://pypi.org/project/wsproto/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/h11-0.9[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest