summaryrefslogtreecommitdiff
path: root/dev-python/whatthepatch/whatthepatch-1.0.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-06 23:35:15 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-06 23:35:15 +0100
commite863cb8850b3734386669ced72ba782bf20bde7a (patch)
tree30ab0c010e90446db06e608c1b8fe9616d58f546 /dev-python/whatthepatch/whatthepatch-1.0.5.ebuild
parentfb6a7e84128cd7df87023d4e7d224de83057f748 (diff)
gentoo auto-resync : 06:05:2023 - 23:35:15
Diffstat (limited to 'dev-python/whatthepatch/whatthepatch-1.0.5.ebuild')
-rw-r--r--dev-python/whatthepatch/whatthepatch-1.0.5.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/whatthepatch/whatthepatch-1.0.5.ebuild b/dev-python/whatthepatch/whatthepatch-1.0.5.ebuild
new file mode 100644
index 000000000000..28281938d7b7
--- /dev/null
+++ b/dev-python/whatthepatch/whatthepatch-1.0.5.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A patch parsing and application library."
+HOMEPAGE="
+ https://github.com/cscorley/whatthepatch/
+ https://pypi.org/project/whatthepatch/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+distutils_enable_tests pytest