summaryrefslogtreecommitdiff
path: root/dev-python/whatthepatch/whatthepatch-1.0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-13 01:35:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-13 01:35:20 +0100
commitc5806fcd6b740ecbd62f4fb2e09d8c8dfa2966fc (patch)
tree32b0c57abadad13ba25305af959e636eb410bee0 /dev-python/whatthepatch/whatthepatch-1.0.2.ebuild
parentad4a5451f677f33e2de05548b45fb92a8b3d04da (diff)
gentoo auto-resync : 13:07:2022 - 01:35:20
Diffstat (limited to 'dev-python/whatthepatch/whatthepatch-1.0.2.ebuild')
-rw-r--r--dev-python/whatthepatch/whatthepatch-1.0.2.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/whatthepatch/whatthepatch-1.0.2.ebuild b/dev-python/whatthepatch/whatthepatch-1.0.2.ebuild
new file mode 100644
index 000000000000..3df171e6eecf
--- /dev/null
+++ b/dev-python/whatthepatch/whatthepatch-1.0.2.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A patch parsing and application library."
+HOMEPAGE="https://github.com/cscorley/whatthepatch"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest