summaryrefslogtreecommitdiff
path: root/dev-python/whatthepatch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-13 01:35:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-13 01:35:20 +0100
commitc5806fcd6b740ecbd62f4fb2e09d8c8dfa2966fc (patch)
tree32b0c57abadad13ba25305af959e636eb410bee0 /dev-python/whatthepatch
parentad4a5451f677f33e2de05548b45fb92a8b3d04da (diff)
gentoo auto-resync : 13:07:2022 - 01:35:20
Diffstat (limited to 'dev-python/whatthepatch')
-rw-r--r--dev-python/whatthepatch/Manifest3
-rw-r--r--dev-python/whatthepatch/metadata.xml13
-rw-r--r--dev-python/whatthepatch/whatthepatch-1.0.2.ebuild19
3 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/whatthepatch/Manifest b/dev-python/whatthepatch/Manifest
new file mode 100644
index 000000000000..20338c1e2009
--- /dev/null
+++ b/dev-python/whatthepatch/Manifest
@@ -0,0 +1,3 @@
+DIST whatthepatch-1.0.2.tar.gz 28459 BLAKE2B e24c882fe1ad42f27eeced72d92423d807ac3284bf0045674b78a247a7222bb142d500129b82a32f8fc95934beaa87a378822da2ef80b1d66d98c171b3a15666 SHA512 e77aa6e934f26647b7a060f46eedd8f5984e43b93b7d576cf8d7a930d08e4b3c5c96c79e61e001df405f3f18c07e4296ce79009d9b9e9c721342af9f8560b4cf
+EBUILD whatthepatch-1.0.2.ebuild 434 BLAKE2B 4411c0bfc5b2a736bb65d40982d5d4bf23180e3b9bb0c9a5f1f111a4af7a3932545657744826fda453972f3531b8127fb51061efae1a1ef1e9e5a4e97e492613 SHA512 5a6815d944487d007449157fc39d6f4291d88fc01fb55cbb085ed7497978eef1a65d423c16ff56f4f1e11a92228e3533e40c15a9ea28daad0869e2dcb74f3460
+MISC metadata.xml 401 BLAKE2B ee370b7f08a16ea4054d5192831a530a9bceac969b2832d6fe058e98dd7558498afbebf4c1f2102979b2f3c252de73c5b11aafcdfed7044a5218144def4f333a SHA512 2a5c7944923e59032c3e75a0a08339ab4b273a346ef855a8ff61c45cc52ecc847db314b0e733876e6d14c3ca42418d9573a26d7f47213958f44a47c6dcbb6c48
diff --git a/dev-python/whatthepatch/metadata.xml b/dev-python/whatthepatch/metadata.xml
new file mode 100644
index 000000000000..a52b8caec8c1
--- /dev/null
+++ b/dev-python/whatthepatch/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">whatthepatch</remote-id>
+ <remote-id type="github">cscorley/whatthepatch</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/whatthepatch/whatthepatch-1.0.2.ebuild b/dev-python/whatthepatch/whatthepatch-1.0.2.ebuild
new file mode 100644
index 000000000000..3df171e6eecf
--- /dev/null
+++ b/dev-python/whatthepatch/whatthepatch-1.0.2.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A patch parsing and application library."
+HOMEPAGE="https://github.com/cscorley/whatthepatch"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest