summaryrefslogtreecommitdiff
path: root/dev-python/werkzeug/werkzeug-2.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-31 10:50:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-31 10:50:20 +0100
commitc3b55a6be7da027d97d8aef00ef88c3011121a42 (patch)
tree3931524f7f6f9958aa6427f6a11a0df28ff99a30 /dev-python/werkzeug/werkzeug-2.2.0.ebuild
parentc8f83ad526fb6b554daf375e0ad65eb2d56e669b (diff)
gentoo auto-resync : 31:08:2022 - 10:50:20
Diffstat (limited to 'dev-python/werkzeug/werkzeug-2.2.0.ebuild')
-rw-r--r--dev-python/werkzeug/werkzeug-2.2.0.ebuild66
1 files changed, 0 insertions, 66 deletions
diff --git a/dev-python/werkzeug/werkzeug-2.2.0.ebuild b/dev-python/werkzeug/werkzeug-2.2.0.ebuild
deleted file mode 100644
index 8fde10ba7f58..000000000000
--- a/dev-python/werkzeug/werkzeug-2.2.0.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Collection of various utilities for WSGI applications"
-HOMEPAGE="
- https://palletsprojects.com/p/werkzeug/
- https://pypi.org/project/Werkzeug/
- https://github.com/pallets/werkzeug/
-"
-SRC_URI="
- https://github.com/pallets/werkzeug/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- >=dev-python/markupsafe-2.1.1[${PYTHON_USEDEP}]
-"
-# NOTE: remove the loong mask after greenlet gains support for loong
-# see https://github.com/python-greenlet/greenlet/pull/257
-BDEPEND="
- test? (
- dev-python/ephemeral-port-reserve[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- dev-python/pytest-xprocess[${PYTHON_USEDEP}]
- dev-python/watchdog[${PYTHON_USEDEP}]
- !alpha? ( !arm? ( !hppa? ( !ia64? ( !s390? (
- $(python_gen_cond_dep '
- dev-python/cryptography[${PYTHON_USEDEP}]
- ' python3_{8..10} pypy3 # TODO: add py3.11 when ported
- )
- ) ) ) ) )
- !hppa? ( !ia64? ( !loong? (
- $(python_gen_cond_dep '
- dev-python/greenlet[${PYTHON_USEDEP}]
- ' python3_{8..10})
- ) ) )
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=()
- if ! has_version "dev-python/cryptography[${PYTHON_USEDEP}]"; then
- EPYTEST_DESELECT+=(
- "tests/test_serving.py::test_server[https]"
- tests/test_serving.py::test_ssl_dev_cert
- tests/test_serving.py::test_ssl_object
- )
- fi
-
- # the default portage tempdir is too long for AF_UNIX sockets
- local -x TMPDIR=/tmp
- epytest -p no:django -p no:httpbin tests
-}