summaryrefslogtreecommitdiff
path: root/dev-python/werkzeug
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-31 10:50:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-31 10:50:20 +0100
commitc3b55a6be7da027d97d8aef00ef88c3011121a42 (patch)
tree3931524f7f6f9958aa6427f6a11a0df28ff99a30 /dev-python/werkzeug
parentc8f83ad526fb6b554daf375e0ad65eb2d56e669b (diff)
gentoo auto-resync : 31:08:2022 - 10:50:20
Diffstat (limited to 'dev-python/werkzeug')
-rw-r--r--dev-python/werkzeug/Manifest2
-rw-r--r--dev-python/werkzeug/werkzeug-2.2.0.ebuild66
2 files changed, 0 insertions, 68 deletions
diff --git a/dev-python/werkzeug/Manifest b/dev-python/werkzeug/Manifest
index 8c0567ab6ef6..51c105661155 100644
--- a/dev-python/werkzeug/Manifest
+++ b/dev-python/werkzeug/Manifest
@@ -1,5 +1,3 @@
-DIST werkzeug-2.2.0.gh.tar.gz 839619 BLAKE2B b6eae91d9a44d030517be5da13c448cf4a2778db7cde61ce36add8dea6f2ac251b31e71d128c4156f44083a4c1b77e546a7e6c55787d8beb93c49538d45b51fd SHA512 2de05269ccd3d83728d435d2f155887a5fd3f3bda9b71c32ffd64b089116c80e89319870fa082f1c6feeeb797b665521b9692ce6c87dcb48b7fa49b2fc63516b
DIST werkzeug-2.2.2.gh.tar.gz 844463 BLAKE2B 84da3dd89375d6925e7e7018701339ddfd2b608acf6b3f126bd56c2020056511de6ab157de9024069d1342f9bce4b481ba91a06089fff1a3b31f4a851af7f935 SHA512 cded6c7e0b00871366b70a41de45e31323c0fc09300413d0efca98f5a2f8207026fd77c7e5670fde727da377fd02b9b636f390a2524d2b5778e9e3bdbdfe3e3a
-EBUILD werkzeug-2.2.0.ebuild 1770 BLAKE2B a5d65d70e8ca4835a38cc6ffe29c6d10b5f8a0a20ca6a0a23edaaa50981fc8c8dc45008e640ebc33fd2f87a765c521b33f0420f0c6f496e116fd463730e7bad0 SHA512 b3e51e66bc53924f8d3f2e61a08a0d4a6ef8c4434440607a34dfae70109f26f86918b2071d99a6df7f86d64429d48b6ea15bc28b4b912425866c88467b7332b4
EBUILD werkzeug-2.2.2.ebuild 1770 BLAKE2B d060cd8e06d36352772d0f7405544a00a8bdf08afc567ec07448444baf833d1bd2c3a63340d2c624018214361c42ef0cb82cdd96cb74261a724f8980e6264109 SHA512 0c9ef5e65b8d125ca6a0a97369249449215cb5e36c8c0cae3f56f703efb304a51e809ece64b9b330e285ce66a6dda1ebde99c6df8982823531be0d7316cf189a
MISC metadata.xml 368 BLAKE2B 81932229098620395623f9149ac974f19fae9b65ad09943ee5c5d8d03c1e37e76061291c959fe5f004f531a244b3bb335c2a43dd66949c0be43493e45674d0e3 SHA512 67e5b5fea8052c0723820125271ea031ad984e0fe2af21d2423fc559bdc51dfe1d40f2fa5fe11e6d2b8b32216e716900080b859aad146c079ad2b390dd9844cf
diff --git a/dev-python/werkzeug/werkzeug-2.2.0.ebuild b/dev-python/werkzeug/werkzeug-2.2.0.ebuild
deleted file mode 100644
index 8fde10ba7f58..000000000000
--- a/dev-python/werkzeug/werkzeug-2.2.0.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Collection of various utilities for WSGI applications"
-HOMEPAGE="
- https://palletsprojects.com/p/werkzeug/
- https://pypi.org/project/Werkzeug/
- https://github.com/pallets/werkzeug/
-"
-SRC_URI="
- https://github.com/pallets/werkzeug/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- >=dev-python/markupsafe-2.1.1[${PYTHON_USEDEP}]
-"
-# NOTE: remove the loong mask after greenlet gains support for loong
-# see https://github.com/python-greenlet/greenlet/pull/257
-BDEPEND="
- test? (
- dev-python/ephemeral-port-reserve[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- dev-python/pytest-xprocess[${PYTHON_USEDEP}]
- dev-python/watchdog[${PYTHON_USEDEP}]
- !alpha? ( !arm? ( !hppa? ( !ia64? ( !s390? (
- $(python_gen_cond_dep '
- dev-python/cryptography[${PYTHON_USEDEP}]
- ' python3_{8..10} pypy3 # TODO: add py3.11 when ported
- )
- ) ) ) ) )
- !hppa? ( !ia64? ( !loong? (
- $(python_gen_cond_dep '
- dev-python/greenlet[${PYTHON_USEDEP}]
- ' python3_{8..10})
- ) ) )
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=()
- if ! has_version "dev-python/cryptography[${PYTHON_USEDEP}]"; then
- EPYTEST_DESELECT+=(
- "tests/test_serving.py::test_server[https]"
- tests/test_serving.py::test_ssl_dev_cert
- tests/test_serving.py::test_ssl_object
- )
- fi
-
- # the default portage tempdir is too long for AF_UNIX sockets
- local -x TMPDIR=/tmp
- epytest -p no:django -p no:httpbin tests
-}