summaryrefslogtreecommitdiff
path: root/dev-python/unrardll
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-24 20:44:11 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-24 20:44:11 +0100
commit342922f04a58a969ff23806acc427c7ff79119ce (patch)
tree7c491f1183b65ff952aefc31909ea49a54196be0 /dev-python/unrardll
parent27f59f8e16510831cc751de1406f71afbf464653 (diff)
gentoo auto-resync : 24:10:2023 - 20:44:11
Diffstat (limited to 'dev-python/unrardll')
-rw-r--r--dev-python/unrardll/Manifest3
-rw-r--r--dev-python/unrardll/metadata.xml16
-rw-r--r--dev-python/unrardll/unrardll-0.1.7.ebuild33
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/unrardll/Manifest b/dev-python/unrardll/Manifest
new file mode 100644
index 000000000000..1618f09dc303
--- /dev/null
+++ b/dev-python/unrardll/Manifest
@@ -0,0 +1,3 @@
+DIST unrardll-0.1.7.tar.gz 10780032 BLAKE2B 92f852ed9cbc02d4c48093dbd5a7f64f4bc279a7b3a3018247a832a61c263b3be19ec5ea94ffdc78c85bd2737647cc3eb231ae9d0953da1de5f23002e7e6ffdc SHA512 23da519c37e52e5cc032d119d1b723c0f4b4ec2c8a08b8ec24a193395d5530780c65a1c20f69aa58f6976ea5e7481c11b92a472cfbce8c477af14673be2189fc
+EBUILD unrardll-0.1.7.ebuild 729 BLAKE2B dd6e1ef16614c435215413915cd8b299a72edd3782b34b6b7ae00c1bea645bc2017046f791fc8da24e7fa50519b6343d6f021cadc4c3c4f23767993d971ccdd8 SHA512 2f2cd5b2348d66469103a637ebbbb78d4858a04ea1756608a5f017020cc39ee8f91c34ca71aa6bb73c776728a6ae1c4bc750c4f550efd5645c48fc8c439de0bf
+MISC metadata.xml 495 BLAKE2B 5381d6692d93a3b17ede31846a7dfe1f15c46b5307e8aa9beff05ce30a15b025e858288e2050e77010212f3bc3d35d70bb3a465484159129f5dae561d1740d83 SHA512 c3be8e5823cf291a192615c6d9fccf0599471ac0ebce5f339d96a2d69c199a7d9ab503c75753a732ce08aa12ae76bc931ad2700e67ff59b84a2f2e4745c50adf
diff --git a/dev-python/unrardll/metadata.xml b/dev-python/unrardll/metadata.xml
new file mode 100644
index 000000000000..34d0dccf4daa
--- /dev/null
+++ b/dev-python/unrardll/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>eschwartz93@gmail.com</email>
+ <name>Eli Schwartz</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">kovidgoyal/unrardll</remote-id>
+ <remote-id type="pypi">unrardll</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/unrardll/unrardll-0.1.7.ebuild b/dev-python/unrardll/unrardll-0.1.7.ebuild
new file mode 100644
index 000000000000..2c4ab30ac2b9
--- /dev/null
+++ b/dev-python/unrardll/unrardll-0.1.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python wrapper for the UnRAR DLL"
+HOMEPAGE="
+ https://github.com/kovidgoyal/unrardll
+ https://pypi.org/project/unrardll/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# The version constraint is needed to resolve https://bugs.gentoo.org/916036
+# and guarantee the headers are findable.
+DEPEND=">=app-arch/unrar-6.2.12-r1:="
+RDEPEND="${DEPEND}"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ default
+ # https://github.com/kovidgoyal/unrardll/pull/5
+ mv test/basic.py test/test_basic.py || die
+}