summaryrefslogtreecommitdiff
path: root/dev-python/unrardll/unrardll-0.1.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/unrardll/unrardll-0.1.7.ebuild')
-rw-r--r--dev-python/unrardll/unrardll-0.1.7.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/unrardll/unrardll-0.1.7.ebuild b/dev-python/unrardll/unrardll-0.1.7.ebuild
new file mode 100644
index 000000000000..2c4ab30ac2b9
--- /dev/null
+++ b/dev-python/unrardll/unrardll-0.1.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python wrapper for the UnRAR DLL"
+HOMEPAGE="
+ https://github.com/kovidgoyal/unrardll
+ https://pypi.org/project/unrardll/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# The version constraint is needed to resolve https://bugs.gentoo.org/916036
+# and guarantee the headers are findable.
+DEPEND=">=app-arch/unrar-6.2.12-r1:="
+RDEPEND="${DEPEND}"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ default
+ # https://github.com/kovidgoyal/unrardll/pull/5
+ mv test/basic.py test/test_basic.py || die
+}